Jump to content


Photo

Spider III black squares in screen

spider iii not work black squares in screen

  • Please log in to reply
3 replies to this topic

#1 Cristianelqui

Cristianelqui

    Just Startin'

  • Members
  • Pip
  • 2 posts
  • Registered Products:1

Posted 28 September 2015 - 05:11 PM

Hi, I was playing guitar with my amp spider 3 and when changing channels with the pedal FVB express the amplifier became stuck and did not emit sounds and no buttons worked. I decided to turn it off and on, but when I turned it back on no buttons lit up and even the saved presets would not load. the preset display only had a few black boxes. please help this is the only thing that can work at this time and it cost me a lot to have this amp. because i do not want to lose it, thanks in advance.


  • 0

#2 fflbrgst

fflbrgst

    Guru

  • Members
  • PipPipPipPipPip
  • 2530 posts
  • LocationNew England
  • Registered Products:3

Posted 29 September 2015 - 04:08 AM

I have heard of this before, if a factory reset does not do anything, then you will need to bring the amp to an authorized service center for evaluaiton and repair.


  • 0

#3 Cristianelqui

Cristianelqui

    Just Startin'

  • Members
  • Pip
  • 2 posts
  • Registered Products:1

Posted 30 September 2015 - 03:31 PM

thanks, but where i can to bring the amp? because here, in chile i can't to find any authorized service center (sorry, i have any bad english, and need to learn more)


  • 0

#4 fflbrgst

fflbrgst

    Guru

  • Members
  • PipPipPipPipPip
  • 2530 posts
  • LocationNew England
  • Registered Products:3

Posted 06 October 2015 - 05:55 AM

    Av. Chile
Servicing: Electronics,Guitars
Espana 393, Nunoa
Santiago
Phone: (56-2) 375-2900
Email: info@audiomusica.com
URL: http://audiomusica.com
  • 0





Also tagged with one or more of these keywords: spider, iii, not, work, black, squares, in, screen