Jump to content


Photo

G10 Not charging

g10 charging

  • Please log in to reply
5 replies to this topic

#1 brenhaze

brenhaze

    Just Startin'

  • Members
  • Pip
  • 7 posts
  • LocationUK
  • Registered Products:3

Posted 27 May 2016 - 08:49 AM

I received my G10 today and it's been charging now for over 8 hours, and no charge held whatsoever.

Just flashing Red and the charging base pulsing Red.

When removed from the base its flashes red, It won't work at all or hold any charge at all :/ 

 

Very disappointing as looking at the FAQ I would of thought after 6 hours of charging I could at least test it a little but nothing.

As the FAQ advised of a small charge after just 2 hours.

 

I've seen a few others with the same problem and units were faulty. I will return it and stick to my G70 and multiple transmitters as I've now seen more people with the same problem :/


  • 0

#2 KuRiXY

KuRiXY

    Just Startin'

  • Members
  • Pip
  • 32 posts
  • Registered Products:2

Posted 16 June 2016 - 04:22 AM

Mine works perfectly, are you using pc-usb or original charger?


  • 0

#3 Line6Tony

Line6Tony

    Line 6 Staff

  • Administrator
  • 2709 posts

Posted 17 June 2016 - 03:13 PM

If you're having charging issues, please make sure you seat the transmitter completely into the receiver, otherwise the transmitter will not charge. For more details, see this article: Relay G10 FAQ


Tony Reese
Line 6 Customer Support Manager


#4 cpwebster

cpwebster

    Just Startin'

  • Members
  • Pip
  • 5 posts
  • Registered Products:2

Posted 19 January 2018 - 07:58 AM

I'm having the same problem, the receiver charged initially, but after leaving it plugged into the transmitter overnight whilst not connected to the mains it appears to have completely drained it's battery and no amount of charging will fix it. Both the transmitter and receiver are permanently flashing red, I've checked that the receiver is docked properly and have attempted an update but it's too flat to complete it successfully, any ideas on where to go next?


  • 0

#5 jbuhajla

jbuhajla

    Power User

  • Members
  • PipPipPipPip
  • 2029 posts
  • LocationDenton TX
  • Registered Products:4

Posted 20 January 2018 - 04:45 AM

I'm having the same problem, the receiver charged initially, but after leaving it plugged into the transmitter overnight whilst not connected to the mains it appears to have completely drained it's battery and no amount of charging will fix it. Both the transmitter and receiver are permanently flashing red, I've checked that the receiver is docked properly and have attempted an update but it's too flat to complete it successfully, any ideas on where to go next?

 

open a support ticket with Line 6


  • 1

Disclaimer: All my opinions referencing the Helix (and all other products) are based upon my personal playing tastes and gear. 

Ephesians 5:19- ...addressing one another in psalms and hymns and spiritual songs, singing and making melody to the Lord with your heart


#6 cpwebster

cpwebster

    Just Startin'

  • Members
  • Pip
  • 5 posts
  • Registered Products:2

Posted 20 January 2018 - 06:07 AM

Have done now, thanks!


  • 0