Jump to content


Pod X3 Pro: Running Gearbox Forces Pc Sound Output To Guitar Amp

  • Please log in to reply
2 replies to this topic

#1 Curtmon


    Just Startin'

  • Members
  • Pip
  • 1 posts
  • Registered Products:2

Posted 01 May 2013 - 07:54 AM

Current OS is Windows 7 64bit Ultra.  According to the Monkey I'm up to date on drivers and software.


When using Gearbox, all sounds/music generated within the PC (Youtube or MP3's) are routed to the POD X3 Pro as sound output which forces my 'band' music through the overdriven guitar amp in turn creating monaural poop.  I have not found a workaround that allows the "Line 6 POD X3 Pro" driver to be enabled and the guitar amp to be separate from the PC output as it should be AND won't need a re-do everytime I re-boot and use Gearbox. 


My typical workaround, when I have the patience, is to disable the "Line 6 POD X3 Pro" driver which correctly routes the guitar output directly thru the POD X3 Pro to the guitar amp and allows the PC generated music to the PC's powered stereo speakers. However each new opening of Gearbox requires a re-fix and it gets old fast.  Plus, on the last attempt this workaround failed to work without a re-boot.   


I need a fix to allow me to finally enjoy this equipment...


thanks in advance,








  • 0

#2 TheRealZap


    Uber Guru

  • Line 6 Expert
  • 17844 posts
  • LocationClemmons, NC USA
  • Registered Products:18

Posted 01 May 2013 - 08:16 AM

the x3 becomes your sound card... the fix is to plug your pd speakers into the x3.

  • 0

#3 Triryche


    Uber Guru

  • Line 6 Expert
  • 7362 posts
  • Registered Products:6

Posted 01 May 2013 - 11:59 AM

+1 to Zap

This is normal operation, not just fo rthe POD X3, but ASIO USB interfaces in general.


Are recording with the POD X3 or sending MIDI to it? If not, don't connect it to the computer.


Otherwise, you should be able to make your PC's soundcrard the default playback device in the control panel. If it reverts back when you plug-in the X3 just change it before you start jamming, you shouldn't have to reboot.

  • 0