Jump to content


Photo

Pod HD500X weird problem

arrow problem settings tap loop

  • Please log in to reply
5 replies to this topic

#1 BlackFaceMao

BlackFaceMao

    Just Startin'

  • Members
  • Pip
  • 2 posts
  • Registered Products:1

Posted 03 January 2017 - 09:13 AM

  Hi, I came here hoping that someone might enlighten me about the problem I'm facing with my device. When I start my Pod, I can see on the screen that the arrow on the different effects on the preset goes all the way to the left. When I use the arrows to go right, it doesn't do anything as if I was holding the left arrow button. I tried to go into the settings and I/O but I can't navigate un the menu, since I need to go right to changes pages and when I try, it stays on the first page. I cleaned the buttons and checked to see if anything got stuck under the plastic but I found nothing.

 

  Also, I don't know if it's related to the pevious problem but my tap and loop switches are acting weird. When I hold the tap button the start the tuner, it goes off of it when I take my foot off. When I leave tuner mode, the loop mode activates and I can't get out of it unless I push several times on the button.

 

  What would you recommend me to do? Reset to factory settings? Ask a post-sale customer service?

 

Thanks a lot for your answers.

 


  • 0

#2 cruisinon2

cruisinon2

    Guru

  • Members
  • PipPipPipPipPip
  • 4879 posts
  • Registered Products:4

Posted 03 January 2017 - 09:29 AM

Won't hurt to try a reset, but I'd be surprised if it makes any difference. Sounds like just a dead button and footswitch...in which case, it's service ticket time.
  • 0

#3 BlackFaceMao

BlackFaceMao

    Just Startin'

  • Members
  • Pip
  • 2 posts
  • Registered Products:1

Posted 03 January 2017 - 02:19 PM

Thank you both for answering, I reset my POD without much hope and indeed, it did nothing. I think I'll keep my POD and repair it when I have the means to. It does seem like there is an internal problem with the switches but I didn't want to go to far into dismantling the device. Thanks again!


  • 0

#4 pianoguyy

pianoguyy

    Power User

  • Members
  • PipPipPipPip
  • 1951 posts
  • Registered Products:2

Posted 04 January 2017 - 05:37 AM

Emphasis on GOOD contact cleaner. 

Don't try buying the stuff for a dollar from a Chinese dealer on Amazon. 

 

What would you rather do, spend a couple extra bucks on the right cleaner or spend the money on a new 500x after it shorts out. 


  • 0

And it sure would be nice if I could use 500edit on my Android Phone or Android Tablet to manage my Pod when not at home.

Even if it needs to be a '500 Lite' version that only allows for the import and export of patches, and not a full-fledged working program.

Something needs done. 

 

 


#5 BillBee

BillBee

    Power User

  • Members
  • PipPipPipPip
  • 2438 posts
  • LocationMichigan
  • Registered Products:8

Posted 04 January 2017 - 06:17 AM

DeOxit is the brand I use.


  • 0

Smell the glove.


#6 pianoguyy

pianoguyy

    Power User

  • Members
  • PipPipPipPip
  • 1951 posts
  • Registered Products:2

Posted 04 January 2017 - 08:17 AM

And don't be fooled by a cheap price on brand name either. 

If every where is selling something for $25 and you see someone selling it for $8... 


  • 0

And it sure would be nice if I could use 500edit on my Android Phone or Android Tablet to manage my Pod when not at home.

Even if it needs to be a '500 Lite' version that only allows for the import and export of patches, and not a full-fledged working program.

Something needs done. 

 

 






Also tagged with one or more of these keywords: arrow, problem, settings, tap, loop