Jump to content


Photo

M13 midi latency


  • Please log in to reply
8 replies to this topic

#1 gib_ber

gib_ber

    Just Startin'

  • Members
  • Pip
  • 3 posts

Posted 27 June 2017 - 09:59 PM

Just bought myself a second hand M13 and set it up to control my Framus Dragon through midi. Everything works as it should, but there is a noticeable ~500ms delay before the amp changes it channel when selecting a scene on M13.

 

Has there been any kind of comment from Line6 how to fix this? 


  • 0

#2 psarkissian

psarkissian

    Line 6 Staff

  • Service Engineer Moderator
  • 1782 posts
  • LocationCalabasas, CA

Posted 28 June 2017 - 08:53 AM

Don't daisy your devices. Use a star configuration with a MIDI interface device.

 


  • 0

#3 gib_ber

gib_ber

    Just Startin'

  • Members
  • Pip
  • 3 posts

Posted 28 June 2017 - 09:30 PM

Thanks for the quick reply. So the only way to achieve simultaneous scene changes and amp channel changes is to get an external midi controller that sends both their own midi commands. :/

 

Does the midi channel selection in anyway affect the possible delay. At the moment I've got both set on Omni.


  • 0

#4 psarkissian

psarkissian

    Line 6 Staff

  • Service Engineer Moderator
  • 1782 posts
  • LocationCalabasas, CA

Posted 29 June 2017 - 07:43 AM

Not usually. It's when devices are connected like a string of beads that delays get stacked up.

With a "star configuration", all delays and arrival times are pretty much equal. It's a general rule

for MIDI in particular and data communications in general.


  • 0

#5 gib_ber

gib_ber

    Just Startin'

  • Members
  • Pip
  • 3 posts

Posted 30 June 2017 - 12:58 AM

Is there anything in the M13 unit that could affect when the midi program command is sent out?


  • 0

#6 kraftybob

kraftybob

    Just Startin'

  • Members
  • Pip
  • 5 posts
  • Registered Products:1

Posted 11 October 2017 - 09:47 PM

Hello:

 

I recently purchased the M13 and a VooDoo Lab Control Switcher so I can change the channel on my DSL40 when switching scenes in latch mode and I'm also experiencing latency when changing channels.  I don't have any other MIDI devices so there isn't anything to setup a "star" configuration for - it's just one midi cable from the M13 to the Control Switcher.  From the little I can find about this online I'm not seeing M9 users having the same problem.  I know the Control Switcher is not the problem as when I manually press the button controlling the channel it switches instantly.

 

Is there any solution for this as this is likely a deal breaker for me as I can't deal with the delay in a live situation.  I have 2 weeks to return the M13 and I'd rather not do that if this can be resolved.   I'm now looking at the Boss GT-100 as that has a built in relay for amp control which is maybe a better way to go so I can bypass MIDI all together.

 

I've read where people say the M13 is not a MIDI controller and I get that.  But I'm not looking to do complicated MIDI programming with it and if it wasn't meant to control anything why have a MIDI out?

 

Any help would be appreciated.  


  • 0

#7 psarkissian

psarkissian

    Line 6 Staff

  • Service Engineer Moderator
  • 1782 posts
  • LocationCalabasas, CA

Posted 12 October 2017 - 07:36 AM

"... why have a MIDI out?"--- to upload and download things like patches or Firmware.


  • 0

#8 kraftybob

kraftybob

    Just Startin'

  • Members
  • Pip
  • 5 posts
  • Registered Products:1

Posted 12 October 2017 - 11:24 AM

...patches and firmware, sure and makes sense.  However, from the manual: The M13 will send and receive MIDI CC and Program Change messages on any MIDI Channel from 1 thru 16 or Omni...

 

If it's going to send MIDI messages, as the manual states, I think it's reasonable to expect that with today's technology, it would be rather instant.  Additionally, from what I can tell, aside from your response (which I do appreciate by the way), Line 6 has been rather quiet on the subject - no updates for the M13 since Jan 2011, etc.  I suspect the M Series is nearing end of life and since there hasn't been an update for over 6 1/2 years I'm not expecting resolution for this issue.  For that reason I think it's in my best interest as a consumer to look at competing products - which is a shame as I really, really like the M13, the sounds, the simplicity, etc., but the latency is a real pain to deal with in a live situation.

 

Thank you for your response.

 

Bob


  • 0

#9 psarkissian

psarkissian

    Line 6 Staff

  • Service Engineer Moderator
  • 1782 posts
  • LocationCalabasas, CA

Posted 12 October 2017 - 01:04 PM

Yes, MIDI MCC. Some use it.

 


  • 0