Jump to content


Photo

M9 Screen Issue


  • Please log in to reply
6 replies to this topic

#1 mf1807

mf1807

    Just Startin'

  • Members
  • Pip
  • 4 posts

Posted 23 December 2013 - 02:11 AM

Hi,

 

I have an M9 and the screen's display is all black. The lights light up but I am not sure if this is a toasted unit or just a firmware unit. I've never got the firmware updated and the unit is in second hand but has no obvious signs of wear.

 

My issue looks identical to this guy's problem:

 

 

Will a firmware upgrade fix it? I cannot see how to do a factory reset. Please help! :(


  • 0

#2 mf1807

mf1807

    Just Startin'

  • Members
  • Pip
  • 4 posts

Posted 23 December 2013 - 12:16 PM

Tried reinstalling the firmware... tried installing old firmware and even then new firmware. The guy on the phone asked me to open the box and look at the ribbon cables which all appear secure. This unit was purchased from an authorized retailer 2013NOV29... making me screwed out of warranty by about 3 weeks. :(


  • 0

#3 smrybacki

smrybacki

    Iknowathingortwo

  • Members
  • PipPip
  • 452 posts
  • LocationCarlisle, PA

Posted 23 December 2013 - 12:27 PM

Sounds stupid, maybe, but is there a contrast adjustment?


  • 0

#4 mf1807

mf1807

    Just Startin'

  • Members
  • Pip
  • 4 posts

Posted 23 December 2013 - 04:55 PM

Not that I can find. So disappointed this Christmas. It doesn't seem like anyone knows what is causing this issue. The unit still functions fine, merely a screen issue
  • 0

#5 mf1807

mf1807

    Just Startin'

  • Members
  • Pip
  • 4 posts

Posted 25 December 2013 - 03:27 AM

An authorized Line6 center says they can peek at it... all time on their bench is 65$ an hour...... Not sure how much it'll be to send it off just yet. The effects still work so I'm thinking it's a screen issue which may require a replacement. Sure wish I could find some answers... Local authorized guys aren't available to look at it until Jan 2.. :(


  • 0

#6 goodthinking

goodthinking

    Just Startin'

  • Members
  • Pip
  • 2 posts

Posted 23 January 2014 - 07:59 AM

There is in fact a display adjustment. In 'Setup' mode, go to the 'Mid/Gate/Display' setting. Top right knob in that window adjusts the contrast display from faded out almost completely (counter-clockwise) to very dense (clockwise). Mine looks about right at what would be around halfway.


  • 0

#7 pjrodz

pjrodz

    Just Startin'

  • Members
  • Pip
  • 1 posts

Posted 27 January 2014 - 01:32 AM

try removing the rubber feet and changing the black painted screws to unpainted ones. solved my problem with my M5(so far). checkout this link http://line6.com/sup...ew/thread/88421


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users