Jump to content


Photo

Is This A New Feature Or A Problem?!


  • Please log in to reply
12 replies to this topic

#1 pugdealer

pugdealer

    Iknowathingortwo

  • Members
  • PipPip
  • 172 posts
  • LocationPortugal

Posted 08 January 2014 - 02:46 AM

Hey guys

 

Just updated the HD500 do 2.2 and have the JTV on 2.0. I noticed that if, for example, I'm on a patch set to acoustic 1 on the JTV (or anything else) and then move the PU selector it will change the acoustic sounds on the JTV regardless of where the model selector is...

 

so, i.e. the patch is set for acoustic, the model knob is on T-model, and when moving the PU selector it changes acoustic sounds rather than T-model sounds as before...

 

so, is this a new feature or a problem?

 

Hope that was clear enough...


  • 0

#2 edstar1960

edstar1960

    Power User

  • Members
  • PipPipPipPip
  • 1195 posts
  • LocationUK

Posted 08 January 2014 - 04:35 AM

Hi pugdealer,

 

I chimed in with an answer on the HD500 forum for this.

 

I had the same scenario when I updated to fw 2.0 - I figured it was working as designed.   If the HD500 has forced a model change on the JTV, the pick up selector then just chooses other models from that same forced bank, regardless of where the model knob is actually at.  To get it to use the model bank selected on the JTV, you have to manually move the model knob to the desired bank and then move the pu selector.  If it is already on the desired bank - then move it away and back again.

 

This will only be an issue if you manually change JTV pickups to a different guitar model bank after the HD500 patch change has forced a model change for you.  If you allow the HD500 to control the JTV model changes in all instances then it should not cause you any issues.


  • 0

#3 Rewolf48

Rewolf48

    Iknowathingortwo

  • Members
  • PipPip
  • 357 posts
  • LocationUK

Posted 08 January 2014 - 04:56 AM

This was a feature request because it didn't used to work this way - it was a pain if the JTV patch and bank was changed from the HD because you couldn't use the JTV patch change as it would go to whatever the JTV Bank setting was.  I and others wanted it so that if you switched to a Spank patch via the HD you should be able to change to other Spank pick-up positions without looking down and fiddling with the Bank knob.

 

But our suggestion was to add to HD500 options so that you could set how it worked, and to my knowledge it had not been implemented in the latest firmware updates.  I will need to check this out.

 

If they can just sort out the alt-tuning problem that would be good (set an alt tuning on the HD, change JTV patch or pickup position and save HD patch the alt tuning setting on the HD has reverted to don't force, but you won't find this out until you swap HD patches as the JTV stays in the altered tuning)


  • 0

#4 edstar1960

edstar1960

    Power User

  • Members
  • PipPipPipPip
  • 1195 posts
  • LocationUK

Posted 08 January 2014 - 05:04 AM

Thanks for confirming it is working as designed Rewolf48.  Makes sense that if you use an HD500 patch that uses a Strat model that the pu selector on the JTV will then allow you to choose pu selections within that bank rather than changing models to match whatever is physically set by the JTV model knob.. So you effectively have a complete virtual strat.   It's just an issue if someone wants to jump from the forced model bank to a completely different model bank using the pu selector mid song and perhaps used to exploit the fact that if the model selector was set to a different bank that the physical setting of the JTV would override the forced setting from the HD500.  However, it is more logical to behave as you described with v2.0 - so when in strat or LP  or semi banks as selected by the HD500 patch that the physical position of the model knob on the JTV is ignored - so you effectively can physically switch pu's like on a real guitar for that model rather than having to select another HD500 patch to swap pu's only.   Thanks again for clarifying.


  • 0

#5 pugdealer

pugdealer

    Iknowathingortwo

  • Members
  • PipPip
  • 172 posts
  • LocationPortugal

Posted 08 January 2014 - 11:26 AM

Ok...that's fine by me...I just needed to know if this was normal or not!
Thanks guys


  • 0

#6 brue58ski

brue58ski

    Gear Head

  • Members
  • PipPipPip
  • 516 posts

Posted 08 January 2014 - 03:30 PM

I like this iimplementation.  Wish I'd known about it earlier.  Now about the HD500, Workbench compatability................... :(


  • 0

#7 Rewolf48

Rewolf48

    Iknowathingortwo

  • Members
  • PipPip
  • 357 posts
  • LocationUK

Posted 09 January 2014 - 05:01 AM

Well I tested it last night and my set-up doesn't work that way  :(

 

Select Acoustic Bank and 12 string Patch so really obvious, switch to Strat P3 using HD500 forced and then on JTV change the Patch from 2 to 4 and...  I have an Acoustic 12 string going through the amp.

 

However I think I might still be on HD500 2.1 as it didn't seem worthwhile doing the update - will try it on Friday as rehearsal tonight.


  • 0

#8 Rewolf48

Rewolf48

    Iknowathingortwo

  • Members
  • PipPip
  • 357 posts
  • LocationUK

Posted 13 January 2014 - 05:04 AM

Ok I have updated to HD 500 2.2 and I was already on JTV 2.0, and it doesn't work that way for me. 

 

If I have JTV on Acoustic (3) for example and use the HD 500 to go to Spank (3) when I move the Pickup selector I get amplified 12 string Acoustics rather than in between Strat position.

 

Can anybody else confirm whether or not there has been a change in behaviour?

 

I would like to be able to switch pickups within a simulated guitar without having to set the knob first - it may be that I need to recreate the HD500 patches from scratch to enable this feature, but it would be nice to know if this was an undocumented change in an update


  • 0

#9 arislaf

arislaf

    Power User

  • Members
  • PipPipPipPip
  • 1095 posts
  • LocationGreece

Posted 13 January 2014 - 05:35 AM

Rewolf, for me also it doesn't work that way, but i like it.


  • 0

#10 edstar1960

edstar1960

    Power User

  • Members
  • PipPipPipPip
  • 1195 posts
  • LocationUK

Posted 13 January 2014 - 06:28 AM

I have just tested this again.  I am currently on HD500 v2.2 and JTV v1.9.  I have page 7 of setup view LOCAL CONTROL: UNLOCKED.    It is still behaving as OP described, which is the bank forced by the HD500 model change is what is recognised by the pickup selector switch, and not the bank actually lit up by the JTV Model control knob.    To get it to recognise the bank on the JTV knob, I have to move the model knob, and then the pickup selector will choose models from within the newly selected bank.

 

I wonder -  Rewolf48 and arislaf - on page 7 of the setup view, do you both have LOCAL CONTROL: LOCKED  ?    Rather than UNLOCKED  ?


  • 0

#11 edstar1960

edstar1960

    Power User

  • Members
  • PipPipPipPip
  • 1195 posts
  • LocationUK

Posted 14 January 2014 - 03:37 AM

Ok I have updated to HD 500 2.2 and I was already on JTV 2.0, and it doesn't work that way for me. 

 

If I have JTV on Acoustic (3) for example and use the HD 500 to go to Spank (3) when I move the Pickup selector I get amplified 12 string Acoustics rather than in between Strat position.

 

Can anybody else confirm whether or not there has been a change in behaviour?

 

I would like to be able to switch pickups within a simulated guitar without having to set the knob first - it may be that I need to recreate the HD500 patches from scratch to enable this feature, but it would be nice to know if this was an undocumented change in an update

 

OK - this is odd - I had rolled back to v1.9 and tested this and it was working as per the OP - but I just switched everything on this morning and now it is NOT working as the OP but working as you have described.   eg: HD500 forced the JTV to a Lester patch, but the JTY had the model knob set to acoustic bank, when I moved the PU selector, I got the relevant model from the ACOUSTIC bank and NOT the LESTER bank.  Which is how it was working yesterday.   Odd !


  • 0

#12 edstar1960

edstar1960

    Power User

  • Members
  • PipPipPipPip
  • 1195 posts
  • LocationUK

Posted 14 January 2014 - 03:39 AM

Ok...that's fine by me...I just needed to know if this was normal or not!
Thanks guys

 

Quick update - I had rolled back to v1.9 and it was working as described but switched all my gear on this morning and discovered it is now NOT working like that but is working back as it did originally - which is - it follows what the JTV model knob is set to if you move the pu selector after the HD500 forces a model change, rather than staying in the bank of the model that the HD500 forced.   I did not do anything in between - it has just started working back as it used to do.  Weird!    :S

 

So we can no longer confirm that the described behaviour is normal - but I am now not sure what is normal because my JTV on v1.9 has swapped between both behaviours!     ???


  • 0

#13 Rewolf48

Rewolf48

    Iknowathingortwo

  • Members
  • PipPip
  • 357 posts
  • LocationUK

Posted 15 January 2014 - 05:10 AM

Local Control is Unlocked on all my HD patches - I do set Tone down for some acoustic patches, but otherwise I don't play with locking - that is really if you are playing Model and Mags together and want to change Mags without altering the Model (e.g. Electric and Acoustic at the same time), or if you are using the JTV knobs as additional Expression Controllers which I don't do as I haven't needed more than Expr 1 and 2 yet.

 

I really want HD to send JTV Bank change because then I don't need to worry about setting the knob in order to change pickups within a model without the risk of getting completely the wrong guitar model, but it looks like it only happens with an accidental combination of versions and cannot be relied on.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users