Jump to content


Photo

Help With Wireless Variax Please?

wireless variax pod xbee

  • Please log in to reply
2 replies to this topic

#1 orangekeeper2

orangekeeper2

    Just Startin'

  • Members
  • Pip
  • 80 posts

Posted 22 May 2013 - 05:44 AM

Hi Folks,

 

Before I begin with this, apologies for the long post. Cutting to the chase, I'm looking for some help... I expect there to be lots of schoolboy errors below and don’t really expect too many responses. I’m conscious this is really old tech and probably a lot of work, but I started this as a bit of fun to see what would happen with no expectations…

 

Anyone who had been around the old forums for a while will probably have seen some mention of legacy Variax users wishing to make their variax fully wireless with POD X3/HD (I.e. wireless audio and patch changing). The functionality was introduced as an unofficial patch for the old Vettas but this was never released on the pods.

 

Threads asking about the Wireless Variax/POD combination resulted in the confirmation that it would not be possible. In order to send patch changes, the POD required a physical connection to a Variax (There were suggestions that this was by design from the AES audio connection).

 

Anyway, I started thinking about this and thought that if I connected my HD500 to an old set of 300 Variax guts that I had lying around, then split the RX+ wire (Patch change sent to Variax), it might work. So as as test, I created a cable to connect my guitar as per the following:

 

I found the following information on the old forums regarding the Pinouts on the Variax cable on the old forums.

1 - GND

2 - PWR (7V)

3 - TX+

4 - AES-

5 - AES+

6 - TX-

7 - RX+

8 - RX-

 

Then used the above to connect as follows:

 

1zgb7sy.png

 

 

The result was a success. When the guts were connected to the POD, the display shows a Variax connection (The guts). Then, when I changed patches on the POD, both the guts and the variax settings changed. So in some level of practice at least, the POD could indeed change patches on a remote variax. Using a second set of guts works around the AES limitation.

 

Looking at the pages on Vettaville regarding the Wireless Vetta/Variax update, it suggested that the patch changes were controlled via MIDI and that a wireless midi system could be used:

 

http://www.vettavill....5 Wireless.pdf

 

So I wanted to find a relatively cheap wireless midi system that was low powered. Ideally, The POD would power the sender and the Variax battery would power the receiver. I ended up finding this page about configuring an XBee to send and receive Wireless MIDI data:

 

http://www.ladyada.n...ee/midibee.html

 

Once built, the receiver would be small enough to embed in a guitar (And possibly powered alongside the Variax), or modular so it could be connected to any other Variax...

 

So I bought and built the XBee transceivers and then configured them to transmit at MIDI baud. Testing them confirmed that they were sending wireless data successfully to each other, and for the sender at least, it was powered successfully by the POD, so now I have the following:

 

9abk80.png

 

Note: If this were successful, I’d then simply replace the guitar cable with a wireless guitar system.

 

You’ll see at this point that my transmitter wiring doesn’t match Vettaville’s PDF document. The reason for this is that when I wired as per the PDF, the Xbee didn’t transmit anything at all. However when I powered the XBee from Pins 1 and 2, the used PIN’s 7 and 8 (Rx+ and -) as MIDI data PINs, the XBee was at least sending data when I changed patches.

It's at this point that my project and knowledge both break down. When I change a patch on the POD, I DO see wireless activity on the XBees, so I know that the POD is sending some kind of data through PIN 7. Unfortunately though, the Variax doesn't change it's patch... Something in the XBee MIDI circuit is modifying the signal in such a way that by the time it reaches the Variax, it's no longer valid. As soon as the signal enters the Optocoupler in the transmitter, any outputs from this, or the inverter or the XBee are not recognised by Pin 7 of the Variax, so no patch changes occur.

I honestly think I could get this working if I had a better understanding of what the Midi circuit was doing to the signal on PIN 7 (Remember this single wire when connected to the guitar changes the patch no problem). If I could ensure that the signal received by the Variax from the receiver matched the signal send by the POD, I’m sure this would work.

Here’s what I know:

  • The voltage of PIN 7 from the POD sits between 2-3V. A direct connection to PIN 7 only on the guitar changes patches no problem.
  • After the signal exits the Optocoupler in the transmitter, it’s around 0.2V and then it gets sent to the XBee.
  • The signal from the receiver is also low, but after it hits the inverter, it jumps up to over 7V
  • From what I gather, MIDI isn’t that voltage sensitive so I’m not sure if this is an issue, but I don’t know enough about it.

So…. Questions…

  • Is there anyone still on the forums who has successfully used the Vetta Wireless mod? Did you have to alter the wiring from Vettaville’s diagram or did it just work out of the box???
  • Otherwise, is there anyone here who knows a bit about electronics who could advise on where things may be falling down? Do you know what the Variax is expecting to receive from a current and voltage perspective? If so, could you advise on how I can alter the Transmitter/receiver circuits to suit?

 

If anyone has built midi circuits, I’d love to see someone sanity check the above, especially the wiring of the Pin outs and ins.

Thanks all,

Mike

 

 


  • 1

#2 rad3d

rad3d

    Just Startin'

  • Members
  • Pip
  • 8 posts

Posted 08 December 2013 - 06:45 AM

So - did you make any progress here?  Very interested in how doable this is.


  • 0

#3 orangekeeper2

orangekeeper2

    Just Startin'

  • Members
  • Pip
  • 80 posts

Posted 03 May 2014 - 12:01 PM

Hi mate, sorry for the late reply... Afraid not, I never figured it out dude...


  • 0





Also tagged with one or more of these keywords: wireless, variax, pod, xbee

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users