Jump to content


Line6 Pod X3 Live Stuck On Update Flash - A Solution

pod x3live update flash

  • Please log in to reply
1 reply to this topic

#1 dsobol


    Just Startin'

  • Members
  • Pip
  • 3 posts
  • Registered Products:4

Posted 22 May 2013 - 12:53 PM

Hello all,


I was having thepod x3 live stuck on update flash problem. Finally, finally got it resolved today. This worked for me:


1) Try and use the USB ports located on the back of your computer if possible.  i.e. one that is soldered to your motherboard.

2) Use the version 1.0 firmware.


Note: step one was suggested by Line6Don. Thank you!

Also, after I got the pedal working w/ version 1.0 firmware, I tried updating to the newest firmware and the problem came back.

I went back to version 1.0 and the pedal is working again! Thank goodness...


Good luck y'all.





  • 0

#2 TheRealZap


    Uber Guru

  • Line 6 Expert
  • 17787 posts
  • LocationClemmons, NC USA
  • Registered Products:17

Posted 23 May 2013 - 05:16 AM

i've had that issue once or twice when i had my x3. I ended up having to disconnect everything but the usb cable, that's what worked for me.

I tended to have alot of stuff plugged in...

PA, a couple of guitars, variax, etc...

have you also tried downloading the firmware file and using the flash from file option?

i usually try that if i'm having issues since it takes some parts of the process out of the equation... helps narrow down the troubleshooting.

  • 0

Also tagged with one or more of these keywords: pod x3live, update flash