Jump to content


Photo

Amplifi 75 Going Back


  • Please log in to reply
3 replies to this topic

#1 Freehbird

Freehbird

    Just Startin'

  • Members
  • Pip
  • 3 posts

Posted 27 April 2014 - 12:37 PM

I loved the idea of the AMPLIFi amps, however, I wish I would have looked at this forum before making my purchase.  My AMPLIFi 75 went back to the store today.

 

It's a nice looking amp, and the concept is great.  I just think Line 6 needed some more time or additional feedback on the amps features.  Limiting this amp to only 4 presets was probably the biggest oversight in my opinion.  All of their other amps have preset banks that allow you to store a lot more custom settings.

 

This amp relies heavily on its Bluetooth capability, and it just doesn't work that well.  Whether I was streaming music or trying to update a preset the Bluetooth connection would just drop.  It wasn't constant, but enough to be bothersome.  My iPad was never more than a few feet from the amp, but in the middle of changing something you could tell the connection was lost. 

 

Also when changing a setting it seemed like there wasn't much of a change to the tone.  You could move the sliders in the App all the way up and down, and it didn't sound that much different.

 

Maybe if they develop an AMPLIFi 2 I will come back to check it out.  I will visit the forum first.

 

 

 


  • 1

#2 Brad_Ames

Brad_Ames

    Just Startin'

  • Members
  • Pip
  • 62 posts

Posted 29 April 2014 - 08:14 AM

Sorry to hear that you didn't like it, the BT is really picky using it, can't have other running apps or switch betweens. It is normal for it to cut out when switching sounds and songs though, has to establish a connection with each tone I assume. Though what kind of amp were you looking to get, amplifi might not suit your needs.
  • 0

#3 Line6Tony

Line6Tony

    Line 6 Staff

  • Administrator
  • 2324 posts

Posted 29 April 2014 - 08:59 AM

Freehbird, sorry to see you not have a good experience with AMPLIFi. Were you able to update the amp? Firmware 1.00.5 improves Bluetooth functionality.


Tony Reese
Line 6 Customer Support Manager


#4 Shakey64

Shakey64

    Just Startin'

  • Members
  • Pip
  • 47 posts
  • LocationNorfolk, England

Posted 29 April 2014 - 09:33 AM

Yeah, L6T is spot on. I updated to 1.00.5 as soon as I got my 75 and have had no trouble with bluetooth connectivity.


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users