Jump to content


Photo

POD X3 PRO NOT SWITCHING ON.


  • Please log in to reply
1 reply to this topic

#1 jameswright2839

jameswright2839

    Just Startin'

  • Members
  • Pip
  • 1 posts

Posted 19 June 2014 - 12:33 PM

Hi folks looking for a bit of help. My Pod X3 Pro has stopped working completely. Wont even turn on, was fine an hour or 2 ago, now its dead. Checked the usuals, different power cable, new fuse etc. Nothing. Does anyone else have experience of this happening? Its out of warranty so will have to pay for repairs. Is this something the UK Service Centre will be able to fix?

 

Any advice will be appreciated.

 

Thanks.

 

James Wright.


  • 0

#2 Brazzy

Brazzy

    Gear Head

  • Members
  • PipPipPip
  • 721 posts

Posted 19 June 2014 - 01:46 PM

I heard a while ago the power switch is a weak link in this senario. Might just need to cleaned if it's gotten oxidized or tinged.


  • 0

I mostly play at home  and am always having fun learning how to play guitar so when I post a reply to try and help give ideas you know where I'm coming from. Rock-On!! Oh, and if I don't respond promptly I'm probably playing guitar or my computer locked up from multitasking 'cause I'm using Gear Box, HD500 Edit, Audacity and tab filled browsers all at the same time, Hahahaaaa. Surprisingly enough my 'puter handles the load more times than not. Lastly I'm not a salesman, I'm not trying to sell anyone anything here. "Riffcasts Riffworld" "RiffRumble Entry" "Shifftie" "M.O.S.U.A Two" "Bass Catszz" "Blasted Runtime Error I" "Match 30" "SoundCloud Playlist" "And Ya Know It"
 

DT50_and_DT9901.pngStrat_X3Pro.pngBerm.pngThe_Arsenal.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users