Jump to content


Photo

M13 firmware update issues

m13 firmware flash update

  • Please log in to reply
3 replies to this topic

#1 bcolexxx

bcolexxx

    Just Startin'

  • Members
  • Pip
  • 1 posts

Posted 15 July 2014 - 05:10 AM

Hello people! I'm brand new to the Line 6 forums.

 

I'm having a few issues updating the Firmware on my LINE 6 M13.

 

The pedal is awesome (when it works).

 

So everything stopped working and i stopped getting sound out of it. When I hook up my cables, you can hear this buzzing when you turn the overdrive effects on, so there definately is a connection there, but when you plug the guitar in nothing comes through. I have of course tested out all cables and everything.

 

So I did some digging and I am on something like 1.07 firmware, and I need to upgrade to the newest one.

 

I've been following the instructions that I found here (http://line6.com/sup...structions-r364)

 

They are easy to follow but still nothing. I've tried it using MIDI-OX utility. I download the Sysex file, and follow it step by step. When I'm in MIDI OX and I send the file through to the unit, my little USB Midi device lights up (it has LEDS for Midi in and Midi out, and the Midi Out is flashing indicating that it's sending midi data through the out cable).

 

My poor old M13 just sits there, on the display it says 'Waiting command'

 

I get all the way to the end sending the Sysex data over, but it looks like the M13 is not recieving it.

 

Just wondering if anyone has had any experience with this and if anyone has successfully done it!

 


  • 0

#2 phil_m

phil_m

    Uber Guru

  • Line 6 Expert
  • 5549 posts
  • LocationMinneapolis, MN

Posted 15 July 2014 - 05:23 AM

What MIDI interface are you using? This is probably the biggest thing. It really needs to be one that isn't using the default Windows drivers. The ones that Line 6 recommends in that document are what you should be using. If you have one of those, that's a major obstacle out of the way.

 

Secondly, I'd try using this program instead of the MIDI OX program. http://www.bome.com/products/sendsx

 

Personally, I never got the MIDI OX program to work.

 

One last thing is that you only really need one MIDI cable to do the update. You just need the cable going from the MIDI out of the adapter to the MIDI in of the M13. You don't need two-way communication to do the update.

 

If you follow those steps, you should have a pretty high probability of success.


  • 0
Time is a train
Makes the future the past
Leaves you standing in the station
Your face pressed up against the glass

 


#3 psarkissian

psarkissian

    Line 6 Staff

  • Service Engineer Moderator
  • 200 posts

Posted 15 July 2014 - 07:57 AM

Version 2.04 is the current one.


  • 0

#4 tommybluenote

tommybluenote

    Just Startin'

  • Members
  • Pip
  • 1 posts

Posted 06 September 2014 - 10:41 PM

phil_m, Thanks for the tip about sendsx. When attempting to upgrade to 2.0 using Midi-OX, the process failed with a 'format error'. And left my m13 unit in a bricked state. Cycling power returned to the waiting for upload message, but each time I tried to to this with Midi-OX same error. I installed sendsx, set the midi out accordingly, and as a result, I've upgraded to 2.04.


  • 0





Also tagged with one or more of these keywords: m13, firmware, flash, update

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users