These forums are read only, please use our new forums here.

Main :: POD X3



my usb port is not connecting my x3 live to my computer
by crad1666 on 2013-04-08 08:30:48

i have an x3 live and my usb port is not working i get the message "no devices connected" ive tryed different usb ports,uninstalling and reinstalling the drivers and im getting the same results every time what can i do outside of buying a new unit or taking and spending almost as much as a new unit to fix it at a shop???????????



Re: my usb port is not connecting my x3 live to my computer
by silverhead on 2013-04-08 09:16:30

The problem may not be with the X3L; it may be a compatibility issue with your X3L and your computer. or other usb devices connected to your computer. I would try to narrow it down by temporarily disconnecting other usb devices from your computer, removing any usb hubs, and trying all usb ports on your computer. Finally, you might try using another computer just as a test. If nothing works then I would conclude that there's a problem with the X3L and take it in for servicing (or replace it).



Re: my usb port is not connecting my x3 live to my computer
by TheRealZap on 2013-04-08 11:38:23

if you've not had the uisb dropout fix for your x3, perhaps you could get that done, and it may fix the problem for you....



Re: my usb port is not connecting my x3 live to my computer
by crad1666 on 2013-04-09 15:55:07

ive tryed just about everything i just might have to upgrade and light this one on fire......thanx for ur help



Re: my usb port is not connecting my x3 live to my computer
by crad1666 on 2013-04-09 15:55:42

ill give it a shot thnx




The information above may not be current, and you should direct questions to the current forum or review the manual.