These forums are read only, please use our new forums here.

Main :: Vyzex Editor

Vyzex will not read from my FPP
by yesterdaysbuddha on 2009-09-30 17:42:05


I'm using an M-Audio Midisport UNO usb interface for my Floor Pod Plus.  When I launch Vyzex, fails the auto sense and then goes to sync with the FPP when I click OK.  It try to read from the FPP, will state that it is receiving, but just stalls a 0-13 bytes randomly and the progress bar does not fill.  When I set the connection up manually and skip the auto sense, I get the same results when trying to sync from the FPP.  I can write profiles to the FPP, either en masse or by single channel.  I tried both the M-audio advanced driver and the Windows "class-compliant"  USB audio device driver.  I explored the windows device limit and logitech issues, but my symptoms don't fit the described symptoms for these issues.  I installed everything on my laptop as well, but received the same behavior.  I'm no sure where to go from here, has anyone seen anything like this before?

Thanks in advance!

Re: Vyzex will not read from my FPP
by PsicraftTony on 2009-10-01 01:38:32

Hi Buddha,

M-Audio Uno interfaces are an unusual case - Unlike the rest of the M-Audio interface line, this model has a problem or two in its history. I should point out the obvious fact that I am not a tech support specialist for M-Audio and don't have access to inside details, but in my experience Uno users should be aware of the following:

According to the M-Audio website, there was a defective run of Uno interfaces ( I assume produced sometime in the last five years): Defective units have serial numbers between 31805709001 and 45805704080, with the third digit always being "8". Check your serial number and if your unit is one of these bad ones I believe M-Audio has a replacement program you can enter to get a replacement. Psicraft Designs has had users report issues with various instrument editors of ours when they were used in conjunction with an Uno interface and a large percentage of the cases involved one of these defective Uno units.

The Uno that we have at Psicraft Designs (among the dozens of USB interfaces by a comprehensive list of manufacturers) has worked reliably for many years now: It was used during the development of Vyzex Floor POD Plus and just today (in response to your post) was tested again on Vista and Snow Leopard with a Floor POD plus: It passed all tests without any issues.

All of this said, we did uncover something that might be causing your copy of Vyzex FloorPOD Plus trouble when connecting and editing the instrument: Is your Floor POD Plus set to a specific MIDI channel other than '1' or 'ALL'?

If so, there is a minor tweak to the program's configuration file that you'll need to do manually, or you can simply set your Floor POD Plus to use MIDI channel 1 or to operate in 'ALL' MIDI channels mode:

To set Floor POD Plus’s MIDI Channel, hold the Manual button and press Save to enter MIDI channel mode. The display will indicate the current MIDI transmit/receive channel. Use the Bank Up/Down footswitches to change the MIDI transmit/receive channel. Selecting “All” places the unit into Omni mode – it’ll receive all channels and transmit on channel 1. Press the Manual button to save the MIDI channel selection and exit MIDI channel mode.

Please let us know how it goes. Anyone who needs to use the editor with a Floor POD Plus set to MIDI channels 2-15 should post here for the details - We'll also include the configuration tweak in a future update when one becomes necessary.



Re: Vyzex will not read from my FPP
by mahabub_3 on 2011-10-19 05:10:51

hi  i have a problem to vyzex in floor pod plus .it cannot find the floor pod and to set the instruments midi in and midi out ports, comms channel and midi channel manually from the studio window.

what can i do my midi cabal is Dtech

Re: Vyzex will not read from my FPP
by PsicraftTony on 2011-10-19 10:56:55

Your problem is almost certainly your bargain USB MIDI interface: If it cannot handle the volume of SysEx messages generated by the FloorPOD Plus then all of these issues will be apparent in the editor.

I recommend you try an affordable high quality USB MIDI interface such as those by Cakewalk or M-Audio. These issues will dissapear once you do.


The information above may not be current, and you should direct questions to the current forum or review the manual.