These forums are read only, please use our new forums here.

Main :: POD X3



Effect Footswitches on POD X3 Live not Working?
by guitarno on 2010-01-26 14:47:59

Hi,

          I have a POD X3 Live that I have owned for about 2 years. Everything was working up until just recently. All of a sudden, the "Mod", "Delay", "Comp", and "Tap" footswitches on the floorboard don't work. I can enable the functions manually with the controls near the LCD readout on the POD, or by using Gearbox, and the light on the footswitch will turn on or off when the function is disabled, but the footswitches do nothing.

   Has anyone else had this happen to their POD X3 Live? I don't know what changed, except that I recently updated the flash memory to Ver. 1.21. I noticed it sometime after that. I tried rolling the flash memory back, and doing a reset on the unit, but the switches are still not working.

   Is there some setting I'm overlooking? Maybe this is strictly a hardware issue, and something on the board failed? Does anyone out there have any similar experience to this or know what might be wrong?

Thanks!



Re: Effect Footswitches on POD X3 Live not Working?
by silverhead on 2010-01-26 19:13:36

There's a well known and well documented (on this forum) problem with footswitch failures on older X3 Live models. It sounds like yours is showing the symptoms. If you want to learn all about it you can search the forum. If you just want it fixed, it's a hardware problem that should be fixed at an authorized Line 6 service centre (see http://line6.com/support/serviceCenters/). Line 6 has offered a lifetime warranty  on this problem so it shouldn't cost you anything other than shipping if necessary.

Some users have tried home-made fixes. Not recommended, but if you're interested you can read the forum history.



Re: Effect Footswitches on POD X3 Live not Working?
by guitarno on 2010-01-27 04:10:34

     Thanks for the reply. I guess I thought this was going to be a really rare maybe unique problem. After doing some searching on this issue, it's obvious a lot of people have had this problem. My unit is one of the older ones where the serial number is lower than the point where they started to put in better switches. Maybe I will be able to get it fixed for free at an authorized repair center.

     The weird thing is that the failure happened all at once to four of the switches. The last time I used it, there was no problems with it, everything worked fine. Now all of a sudden, 4 of the switches don't work - they all went out at once.

     Does anyone know if they "Shotgun" all of the switches and replace them all with new ones when an authorized service center does this repair? I would assume that any of the other ones could go out at any moment.

Thanks!



Re: Effect Footswitches on POD X3 Live not Working?
by jmihendrxjmipage on 2010-05-08 12:55:46

Just had a similar issue the down button quit you can tell if they are working or not buy just lightly pressing the buttons, the ones  that are working you will feel the switch throw.

what has happened on mine is the plastic holder that engages the switch has broken allowing the board to flex away from the button that is mounted to the switch.

After taking mine apart it was apparent what happened

So know foot switch untill it gets fixed.



Re: Effect Footswitches on POD X3 Live not Working?
by jmihendrxjmipage on 2013-01-12 16:35:02

They do shotgun the switches and they are covered for as long as you own the instrument




The information above may not be current, and you should direct questions to the current forum or review the manual.