These forums are read only, please use our new forums here.

Main :: POD 2.0, PODxt Family, Pocket POD, FloorPODs



Snow leopard, Java and Line6 Edit... how to make them work?
by rgn213 on 2010-04-03 05:49:12

Hello,

as many users did, I found this error while trying to open line6 edit on snow leopard:

An exception was caught.


java.lang.UnsatisfiedLinkError: cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash()V

App info: Line 6 Edit 3.01 release - build 99 - Fri Oct 27 14:49:03 PDT 2006

Date: 03/04/10 13.59

In thread: Thread[main,5,main]

OS: Mac OS X (10.6.3 i386)

Java VM Version: 1.6.0_17


Stack trace:


java.lang.UnsatisfiedLinkError: cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash()V

at cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash(Native Method)

at cmn.l6java.utils.L6EmbeddedUtils.HideLauncherSplash(L6EmbeddedUtils.java:39)

at line6editbase.app.L6EditorApp.Start(L6EditorApp.java:459)

at line6editbase.app.L6EditorApp.access$200(L6EditorApp.java:42)

at line6editbase.app.L6EditorApp$L6ELauncherBootstrap.OnLaunch(L6EditorApp.java:310)

at cmn.l6java.app.L6App.Launch(L6App.java:194)

I have kind of three problems:

1. can't make line6 edit work

2. can't access the community/support page (when I log in and click any link may lead to forums, or support, or whatever, it opens on a page with a survey and some other stuff, but I can't guess where to access to forums or to technical support)

3. can only find discussion on the problem through google, but there is no way to get a chronological order (e.g. some posts say that line6 edit is totally not compatible with snow leopard; others say that there is a whole community group about it, but the link is unreacheable).

Could please someone help me to understand how to make everything work and or at least how to contact line6 technical support?

Thank you!



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by satsap on 2010-04-03 08:16:13

I have exactly the same problem. Apple recently sent a software update for snow leopard. Maybe that has something to do with it?



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by mc924 on 2010-04-04 22:37:39

I think that Snow Leopard only support  Java 6.

Line 6 Edit now works with Java 5

You must install j2se 5 ( see on the web how to install java 1.5 on snow leopard ).

with j2se 5 it works.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by toneman2121 on 2010-04-05 11:43:37

http://javadl.sun.com/webapps/download/AutoDL?BundleId=11026install this version, no need to remove latest



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by rgn213 on 2010-04-05 15:47:10

Thanks for your replies,

so I'll try to manage it, downgrading java.

Very disappointed, btw.

Thanks again.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by toneman2121 on 2010-04-05 21:51:32

you do not need to remove current java



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by huidobravo on 2010-04-22 15:33:56

Did it work? i have the same problem.. but the link to Java upgrade, is for windows??



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by aaron__aardvark on 2010-04-23 23:23:12

toneman,

I downloaded the file and it has a name: jre-1_5_0_11-windows-i586-p-iftw.exe             Does it work for a Mac?



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by toneman2121 on 2010-04-24 14:54:56

i don't know. never had a mac. i would assume so



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by nistagmo on 2010-04-24 23:13:23
The only way to use Line6 Edit in Snow Leopard is to install VMware Fusion with Windows XP and install Line6 Edit for Windows  and java runtime envoirement 1.5
Remember to enable USB in VMware Fusion ...


See this video:

http://www.youtube.com/watch?v=OoHUwaMVzlc


Re: Snow leopard, Java and Line6 Edit... how to make them work?
by spbrennan on 2010-04-30 17:29:40

I've been absent from the forums for a while hoping that Line 6 would be working on this issue... but I can't seem to find the old threads.  Hmm...

Nistagmo - you're kidding right?  Buy VMware Fusion AND a copy of Windows XP just to compensate for Line 6's inability to recompile an application?  The smiley face at the bottom was a tip-off - but the fact that this thread is labled "Assumed Answered" really makes me question how technically savvy the folks at Line 6 are.

To Line 6 moderators - here's the deal - will there be a solution to the Line 6 Edit/Snow Leopard situation or not.  I am about to buy another PodXT and that decision is based on this issue having a resolution soon.  Tascam, Digitech, Boss, and Zoom all have competing products; and while they might not have applications that do what Line 6 edit does, or even have the same sound quality - I'm willing to take the chance on their responsiveness to an issue that affects their user community.

In the meantime - until Line 6 Edit can run natvely in Snow Leopard, this thread is not "answered".

Frustrated...

SP



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by nistagmo on 2010-04-30 23:48:30

You are right .. I'm on your side ..

How many people want the Line6 edit software compatible with Snow Leopard?
Maybe there is not enough demand ...

Maybe for them is outdated .. .. I don't know.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by satsap on 2010-05-01 06:06:39

I do like the product, but if the support is not there why would I invest anymore money in something I have lost faith in?



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by toneman2121 on 2010-05-01 09:04:42

L6 is not doing anything with edit or the xt anymore. if you want to contact a moderator, you'll have to start another thread as this one has a star next it and they normally don't look at these



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by toneman2121 on 2010-05-02 05:21:28

have you tried gearbox editor? it's free on the download page



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by satsap on 2010-05-02 08:58:36

Its not available for a bass pod.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by nistagmo on 2010-05-02 12:45:55

Pending Line6 make a version for Snow Leopard and you want to edit your sounds, look here:

http://www.youtube.com/watch?v=OoHUwaMVzlc

Wecould start a new thread and claim update



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by hvdh on 2010-05-05 10:18:07

Best way to solve the problem is to sell your POD stuff.

I did !!!

Life is much better now



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by w01w13 on 2010-05-06 13:37:32

Hi,

there is a way to get Line6 Edit to work in OSX SL, but it requires a littlebit of work. Follow these instructions step-by-step, and you should be fine.

1. Download the Apples official Java Update containing 1.5 from Apples support pages:

http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_4

2.Download a SW called "Pacifist", and install it:

http://www.charlessoft.com/

3.Search for 'Terminal' in Finder, and launch it. Once open, go to folder (copy paste this command):

cd /System/Library/Frameworks/JavaVM.framework/Versions

There, we have to unlink the references to 1.6 version java with the following 2 commands:

sudo unlink 1.5

sudo unlink 1.5.0

(It will prompt for Administrator password on first sudo)

4. Now verify that you do not see the 1.5 or 1.5.0 anymore in the list:

ls -l

If they're not, close the Terminal.

NOTE: You HAVE to do this, since otherwise when you install the 1.5 package in Pacifist, it''ll try to overwrite 1.6....and we do not want to do that

5. Open the Pacifist

6. Click "Open Package" once the timer has stopped, and select the file you downloaded in step 1

7. Browse the folderpath under the path:

Contents of the JavaForMacOSX10.5Update4.pkg/System/Library/Frameworks/JavaVM.framework/Versions

8. Select the 1.5.0, right-click on top of it while it's highlighted and select "Install to default location". Repeat for 1.5

9. Close Pacifist.

10. Via Finder, go to "Application -> Utilities -> Java Preferences", and drag & drop the 1.5.0 in list above 1.6.0.

11. Done, launch the Line6 Edit!



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by bassura on 2010-05-12 08:02:04

It works man! Thanks a lot for that.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by w01w13 on 2010-05-12 12:07:25

Great that it was useful, I work in IT myself do it was not a big thing to fix it once you know how to use the "fine adjust sledgehammer" with computers.

One note that I forgot to mention; if OS X offers you to update Java to newer version, you'll have to repeat the steps here after you upgrade the OS. So keep a copy of the instructions & necessary SW in harddrive in case the thread dies here / or Apple removes the Java 1.5 SW from their site.

-w-



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by w01w13 on 2010-05-12 12:07:52

Whoops, too many beers, so I reposted the reply



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by aaron__aardvark on 2010-05-13 20:52:25

w01,

OK, I did step #1.  I have OSX 10.6.3.  At: install Java for Mac OSX10.5 Update 4, I tried to download it to my hard drive.  It gave me a message: "Java for Mac OSX10.5 Update 4 can't be installed on this disk.  This software can only be installed on Mac OSX Leopard."  I'm I doing something wrong?  What do I do next?.............Edit: I couldn't open my Arturia Prophet V and Arturia Analog Factory software due to eLiceser issues until I put the Java for Mac OSX10.5 Update 4 in the Trash & emptied the trash, and then re-booted my computer.  I have never had that problem before.  I don't think I'll try that again.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by w01w13 on 2010-05-14 11:45:00

Hi,

the instruction said to download the file, not to try to install it by itself. The error you saw is because you tried to execute the update package, and it's earlier version of Java which was originally released for Leopard. So OS X prevents that. This is the reason why you got the message.

Deleting the downloaded file into trash and rebooting could'nt have solved any issues, unless you ment that you installed the Java with the Pacifist, and then uninstalled & rebooted the machine.Just downloading a file to OS X from Apple's site cannot break the system as you mentioned. Executing the package  shouldnt be either the case. But this sounds like you have a compability issue between different Java based apps - the SW you're mentioning is probably needing the new Java, while the Line 6 SW needs the older java. In short, you most probably can't have both working at the same time.

-w-



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by aaron__aardvark on 2010-05-15 09:59:02

w01,

I haven't tried again to get Line 6 Edit into my Snow Leopard iMac, but I thought I should report this: last night I upgraded my Cubase LE4.1.2 to 4.1.3, and after that I had the same weird eLicenser problem.  I think I discovered why: I had my Arturia Analog Factory Experience keyboard hooked up with the USB cable to the iMac while upgrading the Cubase (and earlier with the Java stuff).  Once I disconnected the Arturia keyboard from my computer & re-booted the iMac, the eLicenser problem went away (again).  I did the same thing (along with many other things) when I got out of my eLicenser problems when doing the Java thing.  I know now not to have my Arturia keyboard hooked up to my iMac when downloading new software.  Thanks for responding!



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by nistagmo on 2010-05-15 14:38:29

GREAT!!!

WORK IT!!!

THANX



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by dagga36 on 2010-06-09 13:37:23

What a joke!! WHY is this not supported??

Get a fix PLEASE Line 6!  My Pod is totally pointless without the edit



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by beatntrack on 2010-07-27 07:33:57

I just upgraded my Mac OS to Snow Leopard only to find Line 6 edit for my POD xt does not work. I see lots of others are having a similar issue. I have hundreds of patches for my show that have to be reorganized every week and this is a big problem now.

LINE 6  GET WITH THE TIMES! MAC USERS ARE NOT A SMALL INSIGNIFICANT COMMUNITY.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by nicktrout on 2010-08-12 00:38:19

a



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by mdmayfield on 2010-08-13 07:49:18

This has become asinine, ludicrous, and absurd. Even if the problems with Java 1.6 were insurmountable, Line 6 could have developed a native application for Win Vista/7 and Mac Snow Leopard by now.



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by TomekZielski on 2010-08-14 05:44:04

works great



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by djhansen2 on 2010-08-25 04:43:54

awesome!!!!!! thanks for this



Re: Snow leopard, Java and Line6 Edit... how to make them work?
by andygale on 2010-09-05 07:09:58

I did my java downgrade from this link http://www.scribd.com/doc/22853741/Installing-Java-5-Back-on-Snow-Leopard

LINE6 WAKE UP !!!!!




The information above may not be current, and you should direct questions to the current forum or review the manual.