These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort



MIDI Learn with Reaper
by Triryche on 2010-04-06 08:23:39

I am using PF2 as a plug-in, PODxt is the dongle.

My contol surface is a Yamaha S90es keyboard.

I can not seem to get MIDI learn in PF2 to work with Reaper.

Example, I right click a parameter, click midi learn, move a control surface, nothing.

I can do this in Reaper with Reaper's learn function with PF1. It's a bit tedious because Reaper displays every parameter availble form Pod Farm, not just the ones I'm using, but ALL possible parametrs availble in PF, but it works.

The main reason I went for the upgrade was for the MIDI learn function.



Re: MIDI Learn with Reaper
by grumbleweed on 2010-04-06 08:53:15

I have the same problem with Sonar.

One of the Line 6 guys has looked into it but suggests that is it a problem in Sonar - not PF2. Trouble is I marked an answer as "helpful" but the thread is now classed as "answered". If you haven't seen my thread I'll point out that the stand-alone version works fine with the same set-up.

I hoping somebody can come up with a method of getting over this problem as midi learn was a major selling point for PF2.

Grum.



Re: MIDI Learn with Reaper
by Triryche on 2010-04-06 09:01:45

grumbleweed,

I think you can go to you post and change the status to unanswered.

As a PODxt user, I don't think I can even use the standalone .



Re: MIDI Learn with Reaper
by grumbleweed on 2010-04-06 09:49:59

I think I may have sussed out how to do it (make the pedal work, not change the answered status!)

I'm about to try something.... I'll be back....

Grum.



Re: MIDI Learn with Reaper
by Triryche on 2010-04-09 06:37:43

bump



Re: MIDI Learn with Reaper
by stimorol on 2010-04-09 08:22:25

for me the midi learn function was also the main reason for ugrading to PF2.......ik can't get it to work with Cubase 5??



Re: MIDI Learn with Reaper
by Triryche on 2010-04-11 13:00:57

hope this is sorted out before my 30 day trial ends...



Re: MIDI Learn with Reaper
by Line6Ellison on 2010-04-12 00:20:45

I'm still learning the Reaper, and it looks like there are several ways that might be possible to do this.

If any of you Reaper experts out there have additional suggestions, please post!

So here's how I set up a basic track in Reaper 3.4 for my bass guitar with a KORG nanoKey with POD Farm 2 on my UX1 under Windows. I'm going to cover the entire flow here including audio - pick the sections you need (for MIDI control only, skip down to 'F').

A. First off, check how your Line 6 device is set up for recording:

1.) Open the Windows Control Panel

2.) Double-click Line 6 Audio-MIDI Devices

3.) Select "Inputs & Recording"

4.) Make sure the inputs are what you expect, and make note of the channels.

For me (the simplest case), that means "Instrument", with the Record Sends 1-2 as Instrument Unprocessed (as well a 3/4).

B. Now, start Reaper and make sure it can find POD Farm 2!

1.) Select Options->Preferences from the menu.

2.) Under "Plug-ins" select "VST".

3.) Under "VST Plug-in paths", make sure POD Farm 2's directory is there.

4.) If not, click "Add" and add it.  On my system, the VST is in: "C:\Program Files\Line6\POD Farm 2\VST\Line 6"

5.) Hit "Re-scan"

C. To configure Reaper to use your device for audio:

1.) Select Options->Preferences from the menu (if you're not still there from the above).

2.) Under "Audio", select "Device"

3.) Set the Audio System to "ASIO"

4.) Select "ASIO TonePort UX1" for your device (OR WHICHEVER IS FOR YOUR SPECIFIC DEVICE! e.g. GX1, UX2, KB37, whatever you've got).

5.) Pick your inputs - in this example, I'm using 1 & 2 for unprocessed instrument input.

D. Now set up a track with POD Farm 2:

1.) Select Track->Insert New Track to create a track (CTRL-T)

2.) Click the "fx" button on the track, and select "VST".

3.) Select "POD Farm 2 (Line 6, Inc.)" from the list.

E. Set the track for recording guitar/bass and test:

1.) Click the 'in' button, and select "Mono Input->Send 1" (check back to Step A for other setups).

2.) Click the 'ar' button to arm recording (it should be lit red).

3.) Strum your guitar a bit - the level meter should dance.

4.) To monitor the track w/effects, click the "Record Monitoring" button to change its mode.

It's the little speaker icon on the bottom left of the track. Set it to "on" and play - careful of feedback!

5.) Turn monitoring back off for now (took two more clicks here to toggle it to off).

F. Create a second track for MIDI input and test.

1.) Select Track->Insert New Track to create a second track (CTRL-T)

2.) Click the "in" button on the track (near the bottom left of the track, just to the right of the monitoring icon).

3.) Choose "MIDI Input" from the menu, find your controller, and select "All Channels".   (e.g. MIDI Input->nanoKey->All Channels)

4.) Go back to the track controls and make sure the 'ar' button is armed (should be lit red).

5.) Turn on monitoring by clicking the "Record monitoring" button (the little speaker icon again on the track).

6.) Click the 'io' button (middle-top of track) to pick routing options.

7.) Under "Receives", pull down the menu and select "1:" to send to track 1 (e.g. POD Farm 2/Audio).

8.) Push some keys on your control, make sure you see a little red light on the track input bar.

G. Now learn some MIDI in POD Farm 2:

1.) Select the POD Farm 2 interface (if it's not already up, click the 'fx' button on Track 1)

2.) Double-click on the model you want to control (e.g. Blackface Lux amp in the signal flow) to bring up the model's panel.

3.) Right-click on the knob or button you want to control, and select "MIDI Control->MIDI Learn..."

4.) Turn a knob or press a button a few times and you should see the control in POD Farm 2 start responding to your MIDI input.

H. To view learned MIDI and remove them

1.) Click on the assignments view button in POD Farm 2 (it's the middle button to the right of the Line 6 logo, looks like a knob or PacMan).

2.) Click on the show MIDI button (right above the "Clear" column in the list, looks like a circle made of dots)

3.) List should show anything you've learned. If you twiddle a learned knob/control, the matching list entry should highlight.

Almost got through the alphabet....



Re: MIDI Learn with Reaper
by Triryche on 2010-04-12 06:14:00

Line6Ellison,

Thanks for the very detailed response!

I can't will try this when I get home tonite and promptly mark this answered.

I was not inserting a seperate MIDI track to route to the track with PF2 instance, so that is probably my problem.

However, I was able to use Reaper's learn function without using a separate track for the MIDI.

Thanks again!!



Re: MIDI Learn with Reaper
by Triryche on 2010-04-12 21:14:04

Tried it.

Still not working.

After trying to learn I do see it in the assignment view, but the is nothing under the EVENT column.

I can use Reaper's MIDI lern with PF2 witout a problem.



Re: MIDI Learn with Reaper
by Line6Ellison on 2010-04-12 21:36:56

So you're getting an entry in the MIDI assignment view with an empty Event column?  That sounds very odd, and definitely isn't something I've seen happen.

If you don't mind, got a few questions to try to narrow down what's happening:

What MIDI message are you sending? 

If it's not a note or a CC, could you try with one of those?

Which version of Reaper are you using?

What operating system are you using?

Could you train a tone with a few of those empty settings (like on knobs of an amp) and attach it to a post? 

I'd be interested in looking at it.

Thanks!



Re: MIDI Learn with Reaper
by Triryche on 2010-04-13 07:05:24

Correct.

After attempting MIDI learn, the parameters I attempt to learn do indeed appear in the assignment view with the event column blank.

I am using Reaper 3.4 running on Windows Vista 32-bit.

Don’t have my exact specs on me, but it is a Dual core AMD with 4 gigs of RAM.

I can record MIDI just fine, I have tried send both note and CC messages.

On the track set up to send MIDI, armed for recording and record monitoring set to on, the MIDI indicator confirms it is receiving MIDI.

This is sent to the track with PF2 and my audio. The configuration of the audio track confirms it receives the MIDI track.

I will attach a screen shot later tonite of the peculiar assignment view.

FWIW, I am able to assign automation in PF2 to a parameter. And then use Reaper’s learn just fine. And there is no extra MIDI track, it will just write automation envelopes on the audio track. I have successfully assigned 7 parameters to surface controls this way, 2 wheels, 4 sliders, and 1 CC Pedal. Fun stuff!!

Anyways, I’m OK with doing this thru Reaper, and I am probably fine with the upgrade just for the more flexible FX chain.



Re: MIDI Learn with Reaper
by Triryche on 2010-04-13 20:01:41

Here's my screen shot showing the routing for the MIDI track and PF2's assignment view.

Reaper Podfarm2 scrn.jpg



RE: MIDI Learn with Reaper
by ricksox on 2010-04-15 14:14:33

Hello,

This worked for me. I couldn't quite tell for sure but I think you may need to check how your MIDI track is set up

*F. Create a second track for MIDI input and test.

1.) Select Track->Insert New Track to create a second track (CTRL-T)

2.) Click the "in" button on the track (near the bottom left of the track, just to the right of the monitoring icon).

3.) Choose "MIDI Input" from the menu, find your controller, and select "All Channels". (e.g. MIDI Input->nanoKey->All Channels)

4.) Go back to the track controls and make sure the 'ar' button is armed (should be lit red).

5.) Turn on monitoring by clicking the "Record monitoring" button (the little speaker icon again on the track).

6.) Click the 'io' button (middle-top of track) to pick routing options.

7.) Under "Sends", pull down the menu and select "1:" to send to track 1 (e.g. POD Farm 2/Audio).

8.) Push some keys on your control, make sure you see a little red light on the track input bar.*

Steps 7 and 8 are crucial to this if it's going to work. Also, remember to arm your tracks or else the entire process will fail.

I'm going to be doing some video tutorials within the next few days that outlines how to set this up in various DAW's.

Line6Miller



Re: MIDI Learn with Reaper
by Triryche on 2010-04-15 15:32:56

I did several iterations of this procedure.

Here are some better screen shots.

Anyways, as I mentioned before, I can do this with Reaper's MIDI learn no problem,

so I'm not too worried about it at this point.

midi assignment.jpg

Track 2 routine.jpg

tracks armed.jpg



RE: MIDI Learn with Reaper
by ricksox on 2010-04-16 07:55:05

You're almost there though!!! You need to set your MIDI receive to whichever audio track you are using. You haven't set that. I'm going to do a video tutorial on this today. When it's done, I'll post it and let you know.

Line6Miller



Re: MIDI Learn with Reaper
by Triryche on 2010-04-16 08:06:30

Are you saying the MIDI track needs to receive audio from the track with PF2, which would mean the audio track has a send to the MIDI track??

(Didn't see that step in your instructions)

If so, I will try rhis tonite.



RE: MIDI Learn with Reaper
by ricksox on 2010-04-16 09:40:57

Here you go. Watch how I set this up and got it to work. Let me know if it works for you. If it does, make sure to pass it on.

http://line6.com/community/docs/DOC-1873

Line6Miller



Re: RE: MIDI Learn with Reaper
by Triryche on 2010-04-16 10:02:28

Thanks!

Can't wait to try this tonite!!

However, I think you need to correct step 7 in this thread.


The MIDI track needs to Receive from the audio track.

Step 7 had me sending the MIDI to the audio track.

I see what my problem was (is), I was inserting PF2 on the Audio track!!



RE: MIDI Learn with Reaper
by ricksox on 2010-04-16 12:23:30

OK. All done. Let me know if this works for you.

Line6Miller



Re: MIDI Learn with Reaper
by Triryche on 2010-04-16 18:31:46

Line6Miller,

Thanks for uploading the vid and trying to sort this out.

Still not worling though.

At this point I am wondering if it's a Vista thing.

If it is a bug in PF2 or the drivers, I'm sure it will eventually get ironed out.


FWIW, in step 7 of this thread you are sorta saying the opposite of what you do in the video.

Also, on the audio track IO, you might want to uncheck the parent send box otherwise the dry signal will be in the mix.

If I have time I will try to find a free video capture software (any suggestions?)  and I will make a video showing me repeating the procedure in your video.

I know you have to be wondering if I know what the flip I'm doing!!

I will also make a video of my work around using Reaper's learn function.

Have a good weekend!!



RE: MIDI Learn with Reaper
by ricksox on 2010-04-20 16:29:24

It's really strange that this is not working for you. I know that I've had to unplug and re-plug my USB cable a couple of times due to loss of connectivity. This is usually on a fresh start up but once I re-establish connection it's solid.

Test to make sure it works in stand alone first and then launch your session and try setting it up again.

I don't know of any free capture software but I think CamStudio is pretty cheap.

you may want to google this though because there may be some free ones out there.

Line6Miller



Re: MIDI Learn with Reaper
by Triryche on 2010-04-21 10:44:25

Line6Miller,

I know you don't typically respond to PM's, but I sent you one anyway, please read if you have a chance.

I cannot test the stand alone as I have a PODxt.

I will be building a new PC soon, so I think I am done trying to figue this out for now.

I will leave the thread open a bit longer in the event I have time to post a video this week.




The information above may not be current, and you should direct questions to the current forum or review the manual.