These forums are read only, please use our new forums here.

Main :: GearBox



Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-24 15:24:20

Changes to patches in Gearbox do not update PODxt. Line 6 edit works fine, but Gearbox does not. When I press a button on the PODxt, it reflects in gearbox. But changes in Gearbox do not reflect to the PODxt. If I change the tone on Gearbox from the dropdown at the top, it works, but individual controls do not.

Specs:

Windows vista

Direct USB (no Hub) - on a laptop

Driver: 4.0.2.7

USB Firmware: 1.12

Gearbox: 3.72

I've tried re-installing the drivers, changing USB ports, restarting the machine.

I've seen multiple threads for this very issue:

http://line6.com/community/message/26309#26309

class="jive-link-external-small" href="/thread/21259?start=15&tstart=0">http://line6.com/community/thread/21259?start=15&tstart=0

class="jive-link-message-small" href="/message/162503#162503">http://line6.com/community/message/162503#162503

Also:I much prefer the UI in Gearbox to that of Line6 edit, with one exception; the EQ. The little graphic that allows you to use the mouse to set the four bands is soo damn handy, can you guys add that to Gearbox?

p.s. I'm a software engineer, so feel free to get techy so we can get to the bottom of this.



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-24 15:53:29

Here's another person having the same problem:

http://line6.com/community/message/172608

Forsome reason, 'community/' has been removed from the links above. Here's the correct links:

http://line6.com/community/message/26309#26309style="color: #89020f;">

http://line6.com/community/thread/21259

style="color: #89020f;">http://line6.com/community/message/162503#162503



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-25 18:27:36

Come on guys, at least acknowlege there is a problem.



Re: Changes to patches in Gearbox do not update PODxt
by TheRealZap on 2010-08-25 18:38:27

it's pretty much common knowledge for the x3 forums that you don't edit the tone on the hardware with gearbox open it does strange things.

just use one or the other... problem solved. not what you want to hear... but as i said it's known to do strange things if you use both things at once...

if you don't want strange things to happen... don't do it.



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-25 19:04:10

@zap3nc

I object your reality and substitute my own. The whole purpose of Gearbox is that you can edit the tones simultaneously on the device and on your PC. Also, have Line6 ever stated that they accept that 'strange things' happen when using thier software? Can you give me a link to any representative or any online document that says something along those lines? The only admission I've heard is by Line6Miller and he said the problem is usually caused by USB hubs or a faulty PODxt. If that is the case, then why does Line6 Edit work, surley it's using the same communication system.



Re: Changes to patches in Gearbox do not update PODxt
by TheRealZap on 2010-08-25 19:41:22

you don't have to beleive me... i'm on here enough to know what i see posted, and i have no reason to lie to you.... i'm actually trying to help you... sometimes it's not the software that is the issue... it's the expectation... you being a software engineer should know this... that doesn't mean that the software can't be changed to meet the expectation...

i'm just trying to tell you what i know.

the whole purpose of gearbox is so that you can edit tones from your pc.... your expectation of simultaneous editing using both seems to be the issue.

funny things can happen when using hubs... have you tried different usb cables as well?

edit was an entirely different program, with entirely different logic in an entirely different language (java)

the fact that you get different results when you use it..... well... it's not entirely unexpected.

also as i stated earlier my knowledge of issues when editing the hardware and gearbox is based on the x3... not the xt....

so is it fact? who knows.... is it me trying to tell you something that might help... yes.

either way i hope you get some sort of resolution...



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-25 21:50:36

I didn't mean to come across as doubting your integrety. As for Gearbox, lets take a simple example; if i toggle the Delay pedal from the UI, I should see the Delay light go on and off on the PODxt. This doesn't work, it's supposed to but it doesn't. This aint a case of erroneous expectation, it's a feature of the software that does not work. None of the UI elements update the PODxt in realtime (or in anytime for that matter). It used to work ages ago, but it doesn't anymore. The only thing that does work is when I change patch, that does update the PODxt.

As for the differences between gearbox and Line6 Edit, I would assume that the communication is still the same (which I assume is some sort of MIDI over USB).



Re: Changes to patches in Gearbox do not update PODxt
by TheRealZap on 2010-08-26 13:24:10

hopefully one of the L6 gang can set the record straight or confirm it as a bug, or whatever the next step is...



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-27 21:42:05

Ok, I managed to fix my PODxt. However, I'm not quite sure what exactly fixed it. Nor am I able to get the PODxt to replicate the original problem so I can isolate the cause. That being said, this is what I did:

I unplugged the USB from the POD and used my cakewalk UM-1G midi to USB cable instead

I then setup gearbox to use this (the problem was still present while using the MIDI cable connection)

I then pressed the Tune/system button on the PODxt and went to the MIDI settings and tried different combinations of Program and output settings (i noted that setting an output of THRU caused the PODxt to stop communicating altogether)

Frustrated, I plugged back in the USB while Gearbox was running and Gearbox told me it was connecting to the PODxt and then told me it was a new PODxt. Without closing Gearbox, I clicked on a few of the stompboxes (DELAY, MOD etc.) and it was now working.

I have since closed down Gearbox, restarted my PODxt and unplugged the cables and the error no longer occurs when I try it.

I know this procedure aint exactly scientific, but I cannot reproduce the error and therefore cannot narrow down the cure. Hope this helps.

If you dont have a MIDI to USB cable, could someone try just booting up Gearbox with the PODxt connected. Then unplug the USB and plug it back in (maybe to a different USB port), and dont shut down Gearbox. Post a reply if this works.



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-28 00:53:58

OK, I was able to reproduce the problem and isolate the error. You definitley need a USB-MIDI connection (like my cakewalk UM-1G).

Connect the POD via MIDI (not USB)

Run Gearbox and make sure its all working.

unplug the MIDI cable and plug in USB

Gearbox should show a few messages saying its connecting to the PODxt

Note: This fix seems to only last while your windows session lasts. Rebooting your machine or if your machine goes into any low power mode seems to reset it. You'll have to do the fix again to get it working again.

If anyone at Line6 wants a video of the problem and the fix, I'd be more than happy to send one in. Just send me a message.



RE: Changes to patches in Gearbox do not update PODxt
by ricksox on 2010-08-30 08:33:56

Hello,

I've been here at Line 6 for about 5 years and have run into this problem about 3 times with other users.

We were never able to successfully reproduce that issue here with any of our PODs and we thought maybe we had a hardware issue.

The problem with that theory is that every POD that behaved this way with Gearbox worked perfectly with Line 6 Edit.

Based on your discovery, it seems like maybe there is a MIDI ID or USB Firmware issue.

I cannot guarantee we can or will be able to fix it but i can certainly log a bug for our engineering teams.

If you'd like to attach a link to that video that would be great. Thanks.

Line6Miller



Re: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2010-08-30 08:36:06

Hi ruairiua and thanks for the indications.

My problem with the podxt still too e there were the same that you tell in this post!

Exactly the LINE6 EDIT work but the GEARBOX don't WORK when changing parameters (delay chorus eq..).

Only the preset change work! If I try to mod by the podxt evereything goes on!

Line6perry told me that is a bug and that will be fixed in the future releases .. but a year last!

I will try your suggestions e keep you inform!



Re: RE: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-08-30 17:33:02

@Liine6Miller

I've had this problem on my PODxt for quite some time. However, since I fixed the issue, I've only been able to reproduce the problem once. I've tried heaps of things, like power cycling (i hate that term) the PODxt, the laptop, plugging in the USB at different stages. But I cant cause the PODxt to have the same error. If I can find repeatable conditions to reproduce it, I will most definitley send you a video of it, but until then there's nothing I can do.

I would like to know if this fix works for other people too. And if so, any chance of getting a freebie POD X3?



RE: Changes to patches in Gearbox do not update PODxt
by ricksox on 2010-09-02 09:55:41

I can't guarantee you a free POD but I'd certainly like to log this as a bug for our engineering guys so we can hopefully fix it.

It's very strange that it only happens on certain PODs though.

Line6Miller



Re: RE: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2010-09-12 23:31:34

Hi Ruairiau,

Finally I tried your suggestions and I confirm all you sayed in your post!

My system is:

Windows XP SP3

Direct USB on a laptop

Driver: 4.0.2.7

USB Firmware: 1.12

Gearbox: 3.72

I connected with an Edirol USB-MID UM-2EX

Connect the POD via MIDI (not USB)

Run Gearbox and all working!!

unplug the MIDI cable and plug in USB without closing Gearbox software.

Gearbox show me some messages saying its connecting to the PODxt.

Run Gearbox and all working!!

This fix only last while Gearbox session lasts.

You'll have to do the operations above to get it working again.

Thank you all.

Steve



Re: RE: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2010-09-13 00:30:55

@stevecastel

Glad to hear it worked for you mate. I've found that I don't need to do this fix anymore. I did it twice in total and now my POD seems to work fine.

I noticed that you're using a laptop too, so this may interest you; some laptops (like my ASUS M51) have several USB ports, but internally they work off the same hub. It's much the same as having an external USB hub which is a major 'no no' for audio devices.  Anyway, I bought an Express Card USB hub over the weekend and the results have been astouding. My latency is extremely low and I don't get any pops, clicks or any interferance of any sort.

This is the USB hub I got, but you could use any as long as it is USB 2.0 or greater.

http://www.vantecusa.com/en/product/view_detail/407



Re: RE: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2010-09-13 01:12:36

Great Ruairiau!

I 'll suggest you to being a Line 6 Engineer!

I did it 3/4 times but my POD/GEARBOX/USB don't work after i re-start

I have an Express Card-USB too with 2 usb onboard but I never try to connect to it the PODXT.

Sure that as soon as possible i'll inform you about this test!

Thank you and have a good day!

Stevecastel

P.S. : Im sorry for my english!



Re: Changes to patches in Gearbox do not update PODxt
by andrewwlove on 2010-09-13 11:44:29

The same problem as you guys, I got after I upated with the new drivers...

I have Pod XT Pro v 3.02

USB v1.14

Win Xp SP3

...and the same problem with MAC OS X 10.5 !!!

It works only with midi cable and this is frustrating...

Before update with the latest driver it worked fine.

Any help please????



Re: Changes to patches in Gearbox do not update PODxt
by dhewer on 2010-09-13 12:21:48

See my post Gear Box download includes the lastest driver 4.0.2.3????  CPU 100%

I think they have a driver mix up and I am not sure what actully get installed.  Buy I am looking and a New effects pedal - and not from line 6.

Cheers



Re: RE: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2010-09-16 08:26:08

Hi ruairiau!

Your suggestion work fine!

I connect the POD XT on the USB (2.0) of the Express card and now I can set the latency low at all without having scratch, click and pops!

Thanks a lot

Stevecastel



Re: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2011-08-03 01:54:23

The problem was solved?

It seems nothing changed!

Thank you

Steve



Re: Changes to patches in Gearbox do not update PODxt
by ruairiau on 2011-08-03 17:49:07

@stevecastel

Follow the steps I detailed above and it fixes the problem. You need a MIDI to USB cable to do the fix.




Re: Changes to patches in Gearbox do not update PODxt
by stevecastel on 2011-08-17 06:32:41

Thank you ruairiau!!!

Now it works for me too!!

Havea good day!!!




The information above may not be current, and you should direct questions to the current forum or review the manual.