These forums are read only, please use our new forums here.

Main :: Flextone I / II / III / Duoverb / HD147



Line 6 Edit Software Error
by nine_volt on 2010-11-14 17:49:27

I downloaded Line 6 Edit to my Mac with OS 10.6.5. When I open the software, it comes up with the following error window and does not allow the software to work. Any suggestions to get this up and running?

An exception was caught.

java.lang.UnsatisfiedLinkError: cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash()V

App info: Line 6 Edit 3.01 release - build 99 - Fri Oct 27 14:49:03 PDT 2006

Date: 11/14/10 7:44 PM

In thread: Thread[main,5,main]

OS: Mac OS X (10.6.5 i386)

Java VM Version: 1.6.0_22

Stack trace:

java.lang.UnsatisfiedLinkError: cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash()V

at cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash(Native Method)

at cmn.l6java.utils.L6EmbeddedUtils.HideLauncherSplash(L6EmbeddedUtils.java:39)

at line6editbase.app.L6EditorApp.Start(L6EditorApp.java:459)

at line6editbase.app.L6EditorApp.access$200(L6EditorApp.java:42)

at line6editbase.app.L6EditorApp$L6ELauncherBootstrap.OnLaunch(L6EditorApp.java:310)

at cmn.l6java.app.L6App.Launch(L6App.java:194)



Re: Line 6 Edit Software Error
by s0c9 on 2010-11-16 06:58:13

Search the forum....

This is an old common problem.  Java 1.5 is required to run the editor. It will not run under Java 1.6 directly.

You will need to install 1.5 (Java 5) manually from tjhe Sun website as the Editor tries to install it, but it has been moved from the location in which the editor is looking for it.  Installing 1.5 will not impact 1.6 as your primary Java version.

Once 1.5 is installed - re-install the Editor and it might work. If not, you will need JBuster (search forum or google it) and you should be all set.

The most recent version has a couple of known bugs in it.. most common are the inaccurate compressor and the cab mic positions that are off by 1.



Re: Line 6 Edit Software Error
by TheRealZap on 2010-11-16 08:27:56

close... if you read his actual error... he's not only using a java version that is too new 1.6 but he's also using snow leopard... which removed suppoert for the older version of java...

its a hassle to make it work... but here are the instructions if you are interested....

1. Download the Apples official Java Update containing 1.5 from Apples support pages:

http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_4

2.Download a SW called "Pacifist", and install it:

http://www.charlessoft.com/

3.Search for 'Terminal' in Finder, and launch it. Once open, go to folder (copy paste this command):

cd /System/Library/Frameworks/JavaVM.framework/Versions

There, we have to unlink the references to 1.6 version java with the following 2 commands:

sudo unlink 1.5

sudo unlink 1.5.0

(It will prompt for Administrator password on first sudo)

4. Now verify that you do not see the 1.5 or 1.5.0 anymore in the list:

ls -l

If they're not, close the Terminal.

NOTE:  You HAVE to do this, since otherwise when you install the 1.5 package  in Pacifist, it''ll try to overwrite 1.6....and we do not want to do  that

5. Open the Pacifist

6. Click "Open Package" once the timer has stopped, and select the file you downloaded in step 1

7. Browse the folderpath under the path:

Contents of the JavaForMacOSX10.5Update4.pkg/System/Library/Frameworks/JavaVM.framework/Versions

8. Select the 1.5.0, right-click on top of it while it's highlighted and select "Install to default location". Repeat for 1.5

9. Close Pacifist.

10. Via Finder, go to "Application -> Utilities -> Java Preferences", and drag & drop the 1.5.0 in list above 1.6.0.

11. Done, launch the Line6 Edit!



Re: Line 6 Edit Software Error
by parrislspivey on 2010-11-17 13:53:37

I'm having the same problem. I have a new iMac along with my Pod TX live and I can't install the line 6 edit software. I've followed ur instructions but can't get beyond step #1 (see below). I downloaded Apples official Java Update containing 1.5 and tried to install and I got a message stating that it can only be installed on machines with snow leopard- which is what my machine has. Am I doing something wrong?

Thanks

1. Download the Apples official Java Update containing 1.5 from Apples support pages:

http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_4



Re: Line 6 Edit Software Error
by s0c9 on 2010-11-17 14:44:20

zap3nc wrote:

close... if you read his actual error... he's not only using a java version that is too new 1.6 but he's also using snow leopard... which removed suppoert for the older version of java...

LOL

Guess I should have paid a little more attention to the error text....

I've seen that same error posted here SO many times that I scanned the post and replied.

Good catch ~!!



Re: Line 6 Edit Software Error
by TheRealZap on 2010-11-17 15:18:51

since yours is an XT just save the trouble and install gearbox... it is the supported editor for the XT's

this was posted in the flextone category so i assumed that wasnt an option for the original poster...

also i don't think you install it right at step one... just download and keep going....

not worth the hassle for me... so i haven't done it... just passing this along from another thread.




The information above may not be current, and you should direct questions to the current forum or review the manual.