These forums are read only, please use our new forums here.

Main :: AX2 / AxSys



problem with Ax2 212, any ideas?
by rsvp9146 on 2010-11-23 19:18:54

I recently picked up an AX2 212 from a pawn shop to have as a good all around amp. I had one years ago and loved it. I'm having a problem where after 15 minutes of playing, the amp volume starts to fluctuate, kinda like a rotating speaker. If I give the amp a good thunk on the top, it will go back to normal for another 5 minutes or so.

I've read the FAQs on here and did a hard reset. After that I took the circuit board out and lubed up all the control pots with some tuner spray. It's still doing the volume fluctuation thing after 15 minutes.

The display isnt giving any error messages or doing anything to indicate theres a problem. I've read about a heat sink mod as well as replacing the battery on the board. Can anyone offer any insight into these fixes? I'm reasonably handy with a soldering iron, Just need a little advice.

Thanks much.



Re: problem with Ax2 212, any ideas?
by tumenibrother on 2010-12-31 02:18:33

Can't really offer you much more.  The battery merely stores the user defined settings, so replacing this isn't neceesary for the problem you describe.  Earlier posts by me show the process to go into analysis mode so you can check the battery.

I'm not around my AX right now, but it may be the volume pot.  If I recall, changing the actual volume controls (guitar/aux/master) doesn't do anything in the display, so you wouldn't notice any display changes like you would with a bad editable pot.  Good luck



Re: problem with Ax2 212, any ideas?
by TonyG01 on 2011-03-12 09:27:56

This could be the 'heatsink' problem, but changing the 'heatsink' won't necessarily fix the problem. It's likely that the underlying component (a voltage regulator IC) has been thermally compromised (damaged) and as a consequence it needs replacing. It can be done, but note, this is a double sided circuit board and it's really easy to mess things up.

Apologies for being a little vague, but this a repair I undertook a few years ago on a friends AX212 (and I had a lot of reworking to do with the mother board because the 'chip' didn't come out cleanly). I also added a PC fan internally, upgraded the regulator heatsink and added extra vents. Until a few weeks ago this was his working amp and it was regulalry on the road, but its getting tired.

Before you wade in with the soldering iron. take the circuit board out and inspect it, it's worth taking a close look at the regulator and it's heatsink. Constantly thumping the amp won't do it any good in the long term. But with a little care and patience you might get a few more years out it.

Hope this helps



Re: problem with Ax2 212, any ideas?
by midimaestro on 2011-11-30 15:39:30

I realise your post was a while back, so you may have sorted the problem by now.

Alternatively, you may have come across any number of other problems with your AX2 - believe me, I've seen more than my fair share, having owned two very troublesome AX2s, and an equally problematic Vetta II.

I wish I could tell you something more positive, but this is one of the many problems that AX2s develop over time.

You can check out my blog for my own tale of woe regarding both of my AX2s AND my Vetta II.

http://chillthepartyband.blogspot.com/2011/11/are-you-being-served.html

All I can suggest is that you take it to a repair shop ASAP.




The information above may not be current, and you should direct questions to the current forum or review the manual.