These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort



Sending MIDI to DAWs with UX2 Footswitches
by jamesnotjim on 2010-12-21 11:48:51

I have a TonePort UX2 with POD Studio 2 which is my interface for Ableton Live 8 on OS X. I bought a pair of Boss FS-5U footswitches. I want to control the Looper audio effect and the start button in Live. I understand a little about MIDI mapping in Live, but I don't really get how things should be set up in the Line 6 Audio-MIDI Devices control panel.

From what I've read in various Line 6 documentation PDFs, each footswitch should be set so that "To MIDI Out" is "MIDI CC," but I really don't know what the other settings should be. I've experimented a lot, with varying success. I can get one button to work fine. But adding the second creates problems, so I assume I have them fighting each other in the MIDI settings. Any help is appreciated.



Re: Sending MIDI to DAWs with UX2 Footswitches
by acehole777 on 2010-12-21 16:22:43

http://l6c.scdn.line6.net/data/l/0a060b4d107324bb4d4ed34d94/application/pdf/POD%20Farm%202%20Recording%20Setup%20Guide%20%20(Rev%20A)%20-%20English.pdf

section5-2 deals with Ableton Live 8.



Re: Sending MIDI to DAWs with UX2 Footswitches
by jamesnotjim on 2010-12-21 19:43:41

That was helpful, and I learned a lot from it, but it doesn't solve my problems.



RE: Sending MIDI to DAWs with UX2 Footswitches
by ricksox on 2010-12-22 10:14:56

Hello,

Go into the MIDI Tab in teh Hardware Preferences Control Panel and set your foot switches to MIDI CC. Choose a random CC for each switch that's not assigned to anything IE: CC20. Set the switch mode to Toggle.

After that you need to go into Live and assign the looper controls to the same CC's you assigned the foot switches to. That should be in the Live manual.

Line6Miller



Re: RE: Sending MIDI to DAWs with UX2 Footswitches
by jamesnotjim on 2010-12-23 22:06:09

Thanks Miller. That was helpful, though it didn't get me all the way there, due to some peculiarities of Ableton Live's Looper. But, after further investigation, I found a fix, and I'm adding the details here for the benefit of others. Some of the details may be irrelevant, but I'll include exactly what's working for me right now, just in case.

My device is a TonePort UX2 using driver version 5.1.2, though I'm sure it will be similar for many other devices. I'm running Ableton Live 8.2.1 on Mac OS X (10.5.8 / Leopard).

Connect BOSS FS-5U to Footswitch 1 jack of UX2 with a guitar cable. Polarity switch on the FS-5U should be toward the FS-5U's 1/4" jack (this is to the right if you're looking at the pedal from playing position).

POD Farm 2 (standalone) --> Preferences --> MIDI

Make sure the checkbox to the left of TonePort UX2 is enabled (i.e. the square to the left of its name is highlighted) and click OK.

System Preferences --> Line 6 Audio-MIDI Devices --> MIDI --> Settings

In the listing for Footswitch 1, make the following settings:

1. To MIDI Out = MIDI CC

2. MIDI CC/Action = Custom

3. Chan = 1

4. Switch Mode = Momentary

5. Toggle 1/Dn CC = 64

6. Toggle 1/Dn Val = 0

7. Toggle 2/Up CC = 64

8. Toggle 2/Up Val = 127

9. Type a name of your choice in the Preset combo box and click it's save (i.e. floppy disc) icon. Click this Apply and OK buttons.

10. Click the Show All button to leave the Line 6 system preferences pane.

Ableton Live --> Preferences --> MIDI Sync

1. On the bottom half of the preferences dialog, find the listing for "Input: TonePort UX2" and make sure it has an On value in the Track and Remote columns. Then close Preferences.

2. Enter MIDI map mode by clicking the MIDI Map Mode Switch (upper right)

3. Click the Multi-Purpose Transport Button, to select it (I'm assuming you have an instance of Looper on a track already. If not, drag Looper to a track first, and select the track so it's visible. I prefer to do this in Sessions View.)

4. Here's the trick bit: Press and hold the FS-5U footswitch. While it's still down, exit MIDI map mode by clicking the MIDI Map Mode Switch (i.e. same as in step #2).

5. Release the FS-5U.

The thing is, Looper's Multi-Purpose Transport Button is an odd beast. It expects it's on value (i.e. 127) to be followed immediately with an off value (0). This is because it needs to be able to distinguish between a simple click (i.e. 127 followed immediately by 0) an a click-and-hold, since Looper uses a 2-second hold as an undo/redo command (when playing) or as a way to clear Looper's buffer (when stopped).

But, when you're trying to map this in Live, in the usual fashion (i.e. entering MIDI map mode, clicking a button, clicking the footswitch or whatever other controller you want to map, then exiting MIDI map mode), you end up, in this case, inadvertently mapping the second value (i.e. 0) instead of the first (since both the down and the up send a value). Clicking the footswitch down and keeping it there until after you exit MIDI map mode assures that the first value gets assigned.

Now, I can quit messing with MIDI assignments and make some music instead. Thanks to everyone who tried to help and ultimately lead me to a solution. Thanks also to MIDI Monitor (http://www.snoize.com/MIDIMonitor/)a great OS X utility that helped me figure out what was going on here (along with way too much web research, of course.)



RE: Sending MIDI to DAWs with UX2 Footswitches
by ricksox on 2010-12-27 09:45:30

Excellent description. Thanks for following up and providing this for our other members.

Lien6Miller




The information above may not be current, and you should direct questions to the current forum or review the manual.