These forums are read only, please use our new forums here.

Main :: Vetta



not working please help
by chadbesner on 2011-01-16 21:41:21

hey ...ive had my vetta 2 for about 6 months now and never hada  problem with until today....i was at band practice and i used my vetta 2 head for about 3 hours....every time we take a break i turn off my amp and unplug my guitar so that i dont waste pickup batteries....but when i went to turn my amp back on afterwards...i saw a quick flash (kind of like when a light bulb burns out when u first turn it on)...then nothing.....no lights came on ....and after letting it sit to cool off for a bit i tried again a few times but when i flick on the power button nothing at all happens....ive tried different outlets so i know its not my power source...it has to be my head not working anymore....can anyone help me?   is my amp blown ?....can it be fixed by me or does it need to see a repair shop?  if so will it be expensive to fix?



RE: not working please help
by ricksox on 2011-01-21 11:51:21

Hello,

To rule out software I'd suggest you at least try reinstalling the flash memory in the Vetta.

Please see the following FAQ to learn how to do that:

http://line6.com/community/docs/DOC-3762

If reinstalling the flash memory does not change this behavior for you then you should get this amp to your local service center for repair.

The manufacturer's warranty on that amp is 1 year from the date of purchase. If your amp is under warranty and you have a copy of your sales receipt then the repair will cost you nothing.

If your amp is not under warranty then you'll need to pay for the repair which can vary from shop to shop.

http://line6.com/service_centers/

Line6Miller



Re: RE: not working please help
by nirvanicjonas27 on 2011-01-21 12:46:28

doesn't sound good man, but the service centers are awesome




The information above may not be current, and you should direct questions to the current forum or review the manual.