These forums are read only, please use our new forums here.

Main :: POD 2.0, PODxt Family, Pocket POD, FloorPODs



this is actually about Line 6 Edit
by dougserp on 2011-02-04 12:54:15

I'm having another problem now. Line 6 Edit is not working on my computer (iMac OS X 10.6.6). every time i try to open it, it gives me this error message "an exception was caught. Type: java.lang.UnsatisfiedLinkError. Message: cmn.l6java.utils.L6EmbeddedUtils.nativeHideSplash()V"

Why the hell isn't it working? I meet the system requirements...



Re: this is actually about Line 6 Edit
by TheRealZap on 2011-02-04 13:19:44

actually you dont meet the system requirements... apple removed support for java 1.5 in snow leopard...

as a result edit will not work in snow leopard.

you dont mention what device you have... if its an xt, you can just use gearbox as that is what replaced edit...

if it's a different device that uses edit you have 2 choices.... hack your apple to run the older version of java 1.5

OR wait for an update... they have stated that they are working on one... but its been years since the last update and they have not issued a timeframe...

meaning it could be a long wait....

to hack your mac:   (not for the weak)

Follow these instructions step-by-step, and you should be fine.

1. Download the Apples official Java Update containing 1.5 from Apples support pages:

http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_4

2. Download a SW called "Pacifist", and install it:

http://www.charlessoft.com/

3. Search for 'Terminal' in Finder, and launch it. Once open, go to folder (copy paste this command):

cd /System/Library/Frameworks/JavaVM.framework/Versions

There, we have to unlink the references to 1.6 version java with the following 2 commands:

sudo unlink 1.5

sudo unlink 1.5.0

(It will prompt for Administrator password on first sudo)

4. Now verify that you do not see the 1.5 or 1.5.0 anymore in the list:

ls -l

If they're not, close the Terminal.

NOTE:  You HAVE to do this, since otherwise when you install the 1.5 package  in Pacifist, it''ll try to overwrite 1.6....and we do not want to do  that

5. Open the Pacifist

6. Click "Open Package" once the timer has stopped, and select the file you downloaded in step 1

7. Browse the folderpath under the path:

Contents of the JavaForMacOSX10.5Update4.pkg/System/Library/Frameworks/JavaVM.framework/Versions

8. Select the 1.5.0, right-click on top of it while it's highlighted and select "Install to default location". Repeat for 1.5

9. Close Pacifist.

10. Via Finder, go to "Application -> Utilities -> Java Preferences", and drag & drop the 1.5.0 in list above 1.6.0.

11. Done, launch the Line6 Edit!



Re: this is actually about Line 6 Edit
by dougserp on 2011-02-06 14:38:17

thank you very much sir. sorry for leaving that detail out, but your answer still was able to help me. i appreciate it




The information above may not be current, and you should direct questions to the current forum or review the manual.