These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort



Output latency
by Criccle on 2011-03-23 05:23:56

Hi all,

I'm quite new to recording and stuff and recently bought a KB37. I connected it to my pc and installed all included software (Ableton Live Lite 7, Riffworks T4, Reason Adapted and both PODFarm 1 and 2). After installing the software I downloaded Line 6 Monkey (v 1.3.4) which has updated everything to the newest version. After this I thought I was ready to try and play...I started POD Farm, which works perfectly, but I got no output. So in my computer's sound options I made the Line 6 KB37 my primary device for recording and I checked the box: Listen to this device. This enabled me to hear my own guitar but just with incredible lag: 100 - 160 ms lag (measured with DCP).

How can I fix this...? My understanding was that you should be able to just jam using POD Farm and not experience this amount of lag. Maybe I did something wrong somewhere or I'm missing something, but I hope someone can help me.

Thanks!



Re: Output latency
by silverhead on 2011-03-23 06:38:34

Are you monitoring the sound using the KB37? If not, try using its headphones jack or connecting your speakers directly to its outputs. You should also configure your computer to use the KB37 as its soundcard (I'm not sure that checking the 'Listen to this device' box does that).



Re: Output latency
by Criccle on 2011-03-23 06:47:43

Not that I know of, my impression was that the USB cable sent the signal directly to my pc (and therefore my speakersystem). Besides the USB cable I've plugged none in (is this wrong?).

The headphones jack works fine with POD Farm and other programs though, no latency there. But whenever I plug my headphones jack into my pc (microphone input) I get the same latency as before. The same goes for the keyboard, I've added a midi track in Cubase and I still get a way too high latency.

Just to make sure: is it possible to, for example, play an mp3 using iTunes and play guitar (using the KB37) over the same speakersystem simultaneously?


Thanks for the quick answer by the way, hope it'll work soon!



Re: Output latency
by silverhead on 2011-03-23 06:51:59

The best and easiest way to avoid latency is to monitor the sound using your KB37. You should not attempt to use your computer's internal speakers. If you have external speakers, disconnect them from your computer and connect them to the KB37. If you do not have external speakers you should use headphones connected to the KB37 until you get a pair of external speakers. For best results I suggest studio monitors.

With this setup, and by setting your computer to use the KB37 as its soundcard, all sound from your computer (iTunes, mp3 playback, etc.) will be directed to the KB37 and wil be heard through the speakers connected to it. At the same time, the sound of your guitar and Pod Farm processing will be heard without latency. You will have no problems with latency during recording or jamming away with your favourite backing tracks.

While recording, you should also turn off the monitoring function in your DAW (Ableton). You will be using the KB37 to monitor.



Re: Output latency
by TheRealZap on 2011-03-23 06:57:16

assuming we aren't talking laptop... just plug speakers into line6 device and all your computer sounds etc work with no latency...

ideally you need to monitor the sound from the same hardware you are inputing the sound in...

it really just makes sense that passing sound to different hardware is going to be slower than doing it all from one place...

and its actually part of the ASIO specs...



Re: Output latency
by Criccle on 2011-03-23 07:20:29

Thanks for the help! I've tried connecting the KB37 to my VOX amp and it indeed plays everything without latency (really relieverd because of this! ^_^).

Now all that's left is how to best connect it to my speakers. Since I'm just an average user I don't have monitor speakers...up until now I've always used my Auzentech soundcard and a Harman Kardon amplifier with 5.1 dolby surround. What do you guys think would be the best way to connect my KB37 to this amplifier? I really want to keep using it since I don't have the budget for new monitor speakers (unforunately). It has multiple digital inputs and every possible analog input (3,5 jacks and RCA).

Again, thanks for the help so far, hopefully now I can sleep peacefully tonight haha.



Re: Output latency
by silverhead on 2011-03-23 07:29:17

The KB37 is a stereo (not 5.1) soundcard so you should connect it to the Front/main stereo inputs on your Kardon. The sound should be very good, but remember that the Kardon will colour the sound differently than your Vox amp so the two resulting sounds will be different. I suggest you avoid using any 'sound scene' presets that your Kardon system may have built in. Try to get the flattest, least affected sound possible from your Kardon system.



Re: Output latency
by Criccle on 2011-03-24 03:30:54

I got my guitar to work perfectly without any latency. Thanks a thousand times for that!

When I want to play keyboard though, it still has latency...I guess the problem with this latency lies in the software? I've tried different ASIO drivers (ASIO4ALL and the KB37 but even if it says it has only like 6 ms latency it's still more than that.



RE: Output latency
by Line6Don on 2011-03-24 09:20:02

Glad to see you able to find a work around for your latency problem. Now lets see if we can get rid of the lag you are experiencing with your keyboard.

Assuming you are still monitoring it from your KB37 outputs, I think the latency is happening because of the time it is taking for your computer to generate these sounds and send them to your output.

I don't know what operating system you are using so I will try and give you info for fixing this in both.

In Windows:

Navigate to your system's control panel, locate and launch the "Line 6 Audio-MIDI Devices." Verify that the Line 6 Device is your Toneport KB37. Then towards the bottom you have a slider that controls "ToneDirect & USB Audio Streaming, slide it to the left. Doing so should reduce the latency time you are experiencing, but keep in mind it is going to increase the amount of CPU required.

In Mac OSX:

Navigate to your System Preferences. Locate and launch the Line 6 Audio-MIDI Devices. Verify that the Line 6 Device is your Toneport KB37. Then towards the bottom you have a slider that controls "ToneDirect & USB Audio Streaming, slide it to the left. Doing so should reduce the latency time you are experiencing, but keep in mind it is going to increase the amount of CPU required.

Hope this helps, if not please get back to us.



Re: RE: Output latency
by Criccle on 2011-03-24 09:48:22

Hi Don, thanks for the reply. I've already slided it to the left so it can't be that.

On the same window it says: ASIO client: none and buffer size/bit depth: 4096/32 bit. Maybe this has anything to do with the latency?

By the way: I'm running a Windows 7 x86 on an AMD Phenom 2.4 GHz quad-core with 4 GB RAM. This rules out the possibility of not having enough CPU or RAM, since I think it should be more than sufficient.

What I find most peculiar is that POD Farm has no latency (not hearable) and when I add a MIDI track in Cubase it does have latency even though it says it only has like 6 - 12 ms latency.



RE: Output latency
by Line6Don on 2011-03-24 10:04:11

You are right, it definitely is not your computers resources creating this.

Within the Line 6 Audio-MIDI Devices window again, change the bit depth to 24 bit and the buffer size to 256 or 128 if your computer can support that. This might help a little bit.

Although I think the issue is how you are using POD Farm and Cubase together. Are you using POD Farm as a plug in within Cubase or as a stand alone program in addition to Cubase? You need to be using POD Farm as plug in to help reduce latency as well. In addition, once Cubase is launched, navigate to your audio preferences/options menu and make sure that the Line 6 KB37 ASIO is selected and in use not the standard windows MME driver.

Hope this helps, if not please get back to us.



Re: RE: Output latency
by Criccle on 2011-03-25 02:42:56

Hi Don,

Problem solved, a friend of mine came over who had the same problem. What he did was check Reason if the MIDI controls worked, and to my amazement it worked perfectly with the Redrum drum computer. This meant that the problem was within Cubase. So he created an entirely empty new project in Cubase and added the KB37 as Midi controller, loaded a VST instrument and voila, gone latency.

Even though it still says it has 14 ms input latency and 28 output latency, it sounds like it's more arround 10 ms (I don't know exactly, just want to make a point that the latency is gone haha). What he thinks was wrong is that Cubase didn't load the Midi controller on startup, you have to add it manually.

Anyhow, just thought I'd share this with you in case of future similar questions. Thanks for all the help everybody, I'm gonna enjoy the hell out of my KB37!



Re: RE: Output latency
by Line6Don on 2011-03-25 08:13:10

Glad to hear everything is working well now. Thanks again for letting us know your fix!




The information above may not be current, and you should direct questions to the current forum or review the manual.