These forums are read only, please use our new forums here.

Main :: Line 6 X2 Digital Wireless



Transmitter not powering up
by tfancil on 2011-06-12 19:37:39

Last night at sound check I used my xdr95 without any problems and when I returned 1 hour laster for the gig. I went to power up my transmitter and it lit up and when off. I switched batteries and that didn't help so I used my other transmitter and it did the same thing. It powered up and went right off again. Any idea what the cause may be?



RE: Transmitter not powering up
by Line6david on 2011-06-14 14:46:03

Hi,

There is no real troubleshooting advice I can offer if the unit does not power on. It sounds like the XDR95 needs to go to an authorized service center for repair:

http://line6.com/service_centers/

Thanks,

David

Line 6 Customer Support



Re: RE: Transmitter not powering up
by tfancil on 2011-06-14 19:16:48

The unit powers up, it is the transmitter that is the problem and it powers up with all blue lights coming on but then goes off. Both transmitters were doing the same thing. The worst part is that this unit doesn't have a bunch of time on it. I only use it live and I don't gig as much as I used to.



RE: Transmitter not powering up
by Line6Don on 2011-06-23 10:09:44

Hey fancil,

Just as David mentioned, there isn't really any troubleshooting steps we can offer for this situation. Please contact a local Line 6 Service Center to have the transmitters assessed:

http://line6.com/service_centers/




The information above may not be current, and you should direct questions to the current forum or review the manual.