These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort



Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-06-15 21:56:37

Trying to get FC1010 footpedal and Pod Farm 2.02 running on Windows 7 Ultimate x64 married up and working correctly.  I am having an intermittant problem where Pod Farm doesn't respond to program change messages at some point after successfully receiving one.  Midi-Ox shows the messages are sent correctly.  CV for both expression pedals and other Midi control messages used to turn on/off fx in the signal chain work as expected.  The only slightly unusual thing I am doing is sending controller 4 on messages (tap tempo) and controller 17 off (tuner) messages along with the program change.

Anybody seen this or know a work around to restore control (short of exiting Pod Farm and restarting it)?



Re: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-06-17 19:44:56

Additional steps: upgraded drivers to latest, upgraded Pod Farm to 2.50.0.  Removed controller changes from xmit so only patch changes being sent.  No change in symptoms - program changes are not being processed by Pod Farm but CV and controllers still get processed.  Midi-Ox confirms correct channel, etc.

Ideas?



Re: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-06-28 19:50:31

2.51 is same song, 3rd verse...  Sometimes it works, sometimes it's one program change and then it turns a deaf ear to those messages.

I realize this doesn't appear to be a common problem but it makes this useless for a live performance solution until this is bulletproof.



RE: Pod Farm 2.02 not responing to program change intermittantly
by Line6Hugo on 2011-06-30 10:54:20

I am unable to reproduce the problem that you are experiencing when I send just program change from my MIDI controller (using a POD HD500's MIDI Outs) to POD Farm 2.

POD Farm can only work with what is being sent to it, so please ensure that you are just sending program change to the program and try it once more.

Regards,

Line6Hugo



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-07-02 08:41:34

Reconfigured so I am just sending program changes.  First program change works as expected, but second and subsequent are ignored.  Control changes continue to be responded to at all times.  Using Midi-Ox to confirm what is being sent,  Midi devices:

midiprefs.png

CC Settings:

ccassign.png

Setlist1:

setlist1.png

Podfarm after test:

podfarm25-after.png

MidiOx capture:

midiox.png

Since this is new stuff and a new system, there is always the possibilty I'm doing something wrong.  Hence, the inclusion of these screen shots.

Sometimes everything works as it should, but most often it's one and done.  If there are any debugging features in PodFarm that can be enabled and logs collected I would be more than happy to do so.

- Cam



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by MGoBlue on 2011-07-02 13:25:19

Cam and Line6 guys,

I have the same problem with my Shortboard MKII.  Everything will be working fine and PodFarm will suddenly quit responding to all commands from the controller.  I have not been able to determine if midi commands are still coming out of the controller when this happens.  The only way to clear it up is to exit PF, unplug the controller, plug it back in, then restart PF.

I have seen this in 2.0x as well as 2.5 and 2.5.1.  Everything including the firmware on the MKII is up to date according to Monkey.

I had been chalking it up to something funky with my MKII, but after seeing Cam's identical issues, it seems it might be more systemic.

FWIW, this usually happens when I am in one of my few dual tone patches.  I would be happy to post it if you feel it would be helpful.

Thanks,

Mike



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by Whitie60 on 2011-07-06 06:46:01

hey I am having something very similar as well with PF2.02 at the moment but because i am new to Midi I cant understand if I am doing something wrong or not. I have just purchased a new FBV mrkII Express and dont know whether its malfunctioning. I have just made a discussion thread to ask if anyone can help me determine whether its me or the Software or the FBV. basically what happens it that MIDI Learn wont stick in the way that I believe it should and when it does work in Bank Change ( setlist changes) it skips some setlists repeatedly. Looking at Programme Change it appears to work ok but Bank changes wont stick from Midi Learn and when chosen in FBV programmer they have a tendency to jump about and not pick the setlists in a sequential logical way. they avoid the same setlists each time. Dont know if this is because I have recently deleted some. How do you verify that the MIDI messages have been sent and recieved?



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by Whitie60 on 2011-07-06 06:55:21

MJ similar issues but you have made me think of something else in respect of your comments about Dual Tone. I am having sound issues in DualTone with PF2.02. i currently have a support ticket looking into this and with issues in relation to PF2.5. Basically the issues I have with DualTone revolve around the Tone B channnel and some glitches I have found around the Global Gate & its interaction with the A/B button. If I select the A/B button to hear Tone B only when the Global gate is on I get a severe break up in the sound which eventually cuases it to crash out. i am believing that the glitches have been in the programme since release of PF2.01 and not got sorted right into 2.51. now I have glitches in the Midi functions and now from your troubles it seems it may have some links again with the Dual Tone possibly the Global gate. Try it without the Gate on and see what happens then let me know.



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by Whitie60 on 2011-07-06 08:59:37

I just found a Post from 20/04/10 - 14.01 'Standalone Pod farm 2 Midi Learn Problems' by hwhalen. It suggests that problems can occurr in midi messaging and in Midi learn when more than one Midi transmitting device is connected. It goes on to say that matters were resolved eventually by

Two days ago I was actually using the Midi learn feature.

Yesterday it stopped working. I sent the two images to show what happens when midi learning.

I forgot to mention that the selected control image on the PF2 screen did not move.

Today I unselected all the midi devices and respecified the midi interface to use.

Voila midi learn once again works.


Dont know if this helpful. However i do know that some of my MIDI Learn problems occurred when I also had my UX1 connected and that was checked in the Midi Preferences tab. It could be something I suppose. I am a bit dissqapointed that L6 have known about this issue since then and in the releases of newer versions of Podfarm they still haven't corrected the issue.



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-07-09 16:46:10

The suggestion of having the UXx checked in the MIDI tab being at the root of the problems appears so far to be spot on.  Don't know what the UX2 in this case is doing that would cause the MIDI stream to get horked up, but it would appear it does.  As this was an intermittant problem, I won't call it completely cured for a few days yet, but unchecking the UX2 in the MIDI prefs tab and having only the the footpedal selected as the MIDI input source is making things behave at the moment.  Thanks for the suggestion!

Now, if some wizard can 'splain WHY this is so, I would be most appreciative....  UX2 doesn't appear capable of sending program changes...

- Cam



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by MGoBlue on 2011-07-09 18:03:58

Hey Whitie,

I am not using the global gate in this patch, but rather have individual noise gate blocks for each path (I have each set a little differently because they are different amps and gains).  However, I think you might be onto something with the A/B issue.  There is some indication that this might be happening to me when I have been playing with the A/B settings with my MKII, especially if I try leaving the patch with only channel B selected and I go to a single path preset.  I played for a while earlier today and didn't see any issues though - the nature of intermittent problems I suppose.

I will also check my settings for the MIDI preferences and see if I have the same success as ccotrill.

Thanks.



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-07-10 21:19:08

It's back... No changes in config - not even a reboot.  Just shut down Pod Farm and restarted, first program change took, all those after didn't.  Control changes still are processed.  Only a single source (the Midisport Uno) is selected on the MIDI tab.

Ideas?

- Cam



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by Whitie60 on 2011-07-11 02:46:34

ccotrill -sorry to hear that. can you be a bit more specific about the issues . are they related to the Midi learn function still is is the Midi issue something more widespread. I have just bought a new FBV pedal and cant get the Footswitches to make any associations at all in Midi. However the Expression pedal will MIDI Learn anything I ask it to. If you could detail exactly what you are doing it would be helpful. Have you tried to do the programming through a programmer?



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by ccotrill on 2011-07-14 18:27:52

The issue has nothing to do with MIDI learn.  This is strictly a real time MIDI control issue.  Pod Farm 2.x responds to all control changes all the time.  It responds to the first program change after loading, but at some point thereafter stops responding to program change messages.  The only way to get it to respond to program changes again is to shut down Pod Farm and restart it. Control changes are always correctly processed by the assigned controllers.

- Cam



Re: RE: Pod Farm 2.02 not responing to program change intermittantly
by Whitie60 on 2011-07-16 08:44:04

yes I have similar issues. I have sent my New FBV pedal back to see if its the pedal.



Re: Pod Farm 2.02 not responing to program change intermittantly
by Xedian on 2012-07-17 15:13:22

Hey Guys it seems to be that there are a lot of cases with the same issue of POD Farm 2 not responding to midi program changes from a footController, I have the same problem that makes it impossible to use it for a live situation, i use instead Amplitube 3, i own The Guitar Rig by NI too, and they both respond to MIDI prgam changes without any failiure, the most disapointing thing for me is that i really like POD farm2 sound, actually is my favorite! but unfortunatelly the Line 6 crew does not care about that,... its a shame because it could be the best guitar pluguin in the world! but still its NOT!

Give a try at Amplitube 3! you wont have any issues with any midi footpedal controller, it doesnt matter the brand of it, it just WORKS! and the sound is quite good too!

Guitar Rig doesnt have that pro sound of POD Farm or Amplitube but it still works!

I really HOPE that Line 6 fix this midi program change issue!

it really would make PF2 the best plugin in the whole world!

by the mean time i have PF2 just sitting in my HardDisk waiting for an update conserning that matter



Re: Pod Farm 2.02 not responing to program change intermittantly
by jsherwani on 2012-11-14 02:55:43

Hello all,

I just installed POD Farm 2.5 on my Mac (fresh install, never installed POD Farm ever before), and I have the exact same problem in REAPER. I have my POD HD500 connected to my Mac via MIDI, and can confirm that the MIDI inputs are working correctly, and have been wired in correctly.  However, the same problem described above is happening to me too — specifically, POD Farm responds to the first MIDI program change, but all subsequent program change messages via MIDI are ignored.

Has no resolution for this been found in over a year?

J




The information above may not be current, and you should direct questions to the current forum or review the manual.