These forums are read only, please use our new forums here.

Main :: POD Farm / POD Studio / TonePort



OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-07-28 06:25:08

Hi support,

I have a POD X3 PRO rack and use Mac OX10.7 "Lion" [CoreAudio 4.0.0] I have latest available sw from Line 6 via Line 6 Monkey @ time of writing.

I have two major issues:

1) Despite authorizing both my Mac mini computer and POD X3 PRO in the new app. "Line 6 License Manager", in Garageband v6.0.4

   (from iLife '11) [latest version @ time of writing] the POD Farm v1.12 plug-in will still say it is not authorized or not found (it clearly is

    found as Line 6 Monkey finds it) and it is authorized on my account (via authorizing my POD X3 PRO hardware- see attached files),

    and thus it states it will not process any audio . Garageband is set-up to use the latest POD X3 Pro audio driver (v7.0.9) for Audio-in.

   Ideas? Please advise.

2) Same set-up but testing using POD Farm 2 now- not bought however as yet.. trial mode... any Garageband v6.0.4 file using this

    AU Plug-in will crash on re-opening (ie. if saved using the POD Farm 2 plug-in), Note: it will not skip the plug-in either on re-opening..

    so your GB file appears to be corrupted permanently. The GB crash report has been sent to Apple. PS. This test file is using

    no other 3rd party AU plugins and opened fine without POD Farm 2 prior to POD Farm 2 inclusion.

   Ideas? Please advise.

I have not been able to test this in any other DAW as yet.

When will there be a fix/update available?

/Alan



RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by Line6Hugo on 2011-08-02 15:06:09

Alan,

First, can you please use the following link and fill out your computer support profile:

http://line6.com/account/supportProfile/

Now, for your first problem, this would only occur if Garageband is not seeing the authorization from the POD X3 Pro. I suggest completely remove all other USB devices (except for a mouse and keyboard). Completely remove ANY USB hubs, even if not in use, and test the POD on all of the Mac Mini's USB ports.

Also, please make sure you are not using the server version of your OS (like OS Lion Server). We do not support those OS versions.

For your second problem, please provide us a step by step recipe on how to reproduce this problem. Does this happen with a previously existing song file, new song, or both?

Please provide as much detail as you can on the steps you take.

Regards,

Line6Hugo



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-03 13:21:45

Ok, filled out profile now with the same information already sent as attachment in first message.

First problem: POD Farm

I removed all other USB devices as suggested:

USB devices.jpg

I can't remove "Hubs" as all the ports on the Mac mini appear to be "Hubs" (see above). Didn't work.

Tried all ports one at a time. Didn't work. Note: Garageband even gives a message when it detects the POD X3 Pro device on USB when the connector is re-inserted and asks if I want to use it- I say "yes".. but it still doesn't work: POD Farm won't be authorised to be used with my POD X3 Pro. I am not using the server version of Lion, I am using Mac OS X Lion 10.7 (11A2061). Any more ideas?

For re-creating problem 2: POD Farm 2

Step 1.1) open an existing Garageband file or

         1.2) create a completely new Garageband file (doesn't matter, tried both)

        2) Make a new "Real instrument" track + Edit it

        3) Add the AU Plug-in "POD Farm 2"

        4) Save the file

        5) Quit Garageband

        6) Re-open the same file...

        Boom..."Garageband unexpectedly quit- send crash report to Apple?"

I can try and attach the Crash report (I can "see" it happens when trying to load the POD Farm 2 plug-in .. as Garageband opens it scans/reads in the AU plug-ins) if that helps.

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-03 13:33:53

Atttached is the Crash report I sent to Apple for problem 2 above: POD Farm 2.



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by complex69 on 2011-08-04 02:18:17

You need to change the permissions in Users/<Username>/Library/Application Support/Line6. Now in Lion the users//library is hidden by default, but if you google it im sure youll find a solution on finding.

When i changed the permissions on that line6 folder i opened POD Farm and i saw it created files and folders in that line6 directory so i reauthorized through license manager then reopened pod farm, that still didn't work. So i just ran the pod farm installer again, reauthorized in license manager and now it works. I hope this helps.



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by Line6david on 2011-08-04 13:02:31

Hi,

This is likely related to a permissions issue in OSX.

Click on Finder or the Macintosh HD icon on your desktop.

Next go to:

Username>Library>Application Support>Line 6

Is the folder Empty?

If so, control click inside the folder and select Get Info.

Make sure that sharing and permissions for the folder is set to read and write.

Next create a folder inside the Line6 folder called Guitarport.

Run Line 6 License Manager, deauthorize and reauthorize the computer and Line 6 device one more time.

POD Farm should authorize. 

Thanks,

David

Line 6 Customer Support



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-04 14:26:03

Hi complex69,

thanks for the ideas..

Firstly, thanks for the help- very appreciated.

I tried all you did (and Line6david's extras)- and it still didn't authorize POD Farm.

Btw the folder was not hidden, I found it plain as day:

it had both POD Farm and POD Farm 2 folders in it.

I changed the permissions on the Line6 folder though (which were "read only") so they were "Shared" and absolutely everyone could read/write to it... so it looked promising :/.. I deauthorized and re-authorized the computer- tried again and failed.

I then "started afresh", de-authorized computer.. deleted those folders in Library/Application Support/Line6 and re-installed POD Farm, (restarted) .. then re-authorized the computer. Still fails... on this second attempt, I noticed now the folder "Guitarport" (which Line6david asked me to manually create) WAS created by the installer itself.... so it looked even more promising.. but sadly, it still won't authorize Garageband to use the POD Farm plug-in with my Line6 POD X3 Pro. Any more ideas chaps?

The Guitarport (why is this even relevant?) folder is empty .. the POD Farm is not.. it looks like this:

folders.jpg

PS. Any info on my POD Farm 2 problem?

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-04 14:27:59

it didn't- see above reply for more info.

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-04 14:50:20

I just noticed you had suggested:

Run Line 6 License Manager, deauthorize and reauthorize the computer and Line 6 device one more time.

I had not tried de-authorizing the POD X3 Pro itself.... so I tried that and now it is stuck in "Pending" state. The "?" brings up the pop-up telling me to connected the POD X3 Pro (which is connected still) and use a "remove button" which is nowhere to be seen/can't be found(?). I tried switching on/off the POD X3 Pro.. tried moving it to other USB ports (which btw it is found on)... no magic remove button.. it appears stuck now in this "pending" state:

Remove button??.jpg

Also note, I never see the POD X3 Pro in the list of devices, should I?.. just my computer (on scans for devices). Should the Licence Manager list my "POD X3 Pro" as a device in the above view?? It never seems to.. I don't recall it ever listing it.



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by Line6david on 2011-08-05 08:13:07

Hi,

Connect the POD X3. Once license manger can see it, you can remove the add-ons and then reauthorize the device.

This should go into futher detail:

http://line6.com/support/docs/DOC-2295

class="jive-link-external-small" href="http://line6.com/support/docs/DOC-2277" target="_blank">http://line6.com/support/docs/DOC-2277

Thanks,

David

Line 6 Customer Support



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-05 09:06:40

Hi, see above .. the POD X3 is connected: it is listed on the USB device tree etc etc...

As I said: "The "?" brings up the pop-up telling me to connected the POD X3 Pro (which is connected still)" it never left the building... or was disconnected.

License Manager only sees "my computer" as a device... why does it not find or list the POD X3 Pro? That is the problem..or is it? I was asking you: should the "License Manager" list my POD X3 Pro as a device for authorization/de-authorization? Or are you confusing this with the Line6 account which does list both the computer and my registered product (the POD X3 Pro)?

If I must get the License Manager to find my POD X3 Pro hw and list it as a device- how do I do that from here (ie. when the Line 6 server is in this "pending" state), so it can finish this "de-authorizing" .. Note: the authorization appeared to go fine..from the License Manager and web-site account info...  I'm only attempting this de-authorization to attempt re-authorizing because the permissions on the Line6 POD Farm folders appear to have been installed wrong (read only9... and POD Farm ended up never licensed for use.

I never got an answer on the relevance of the "GuitarPort" folder definition....was that relevant?

And is there any progress on the second issue: namely the crash report on POD Farm 2?

PS. Why is de-authorizing the computer and device available as options on the Line 6 account/server.. but only the computer in the "License Manager"?

Is there perhaps even more permissions problems? I noticed for example the License Manager never remembers my login, despite me saying for it to remember me...(a bug in itself, but might be a clue)

/Alan




Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-05 09:13:15

I noticed from DOC-2277:

"

What are the system requirements for the Line 6 License Manager?

The Line 6 License Manager is compatible with the following operating systems:

  • Windows: XP, Vista and Windows 7
  • Mac: OSX 10.4, 10.5 and 10.6


"

What about 10.7? That is what I am using... will there be an update? Doesn't seem to work perfectly....

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-06 06:52:45

Ok, I figured out what your fault is from above pending state (at least)...and I'm sure if you make an update an fix this, you will get alot less confusion surrounding this for Mac OSX Lion users...

If you get into trouble like this and ever clean install POD Farm 1, that (old) installer will knock your driver version back from 7.0.9 (required for Lion) to 4.6.8 (and even Line 6 Monkey it appeared) from 1.41 to 1.33 ... so you have to: re-install Line 6 Monkey from the web site first, then re-update the driver, so the Licence Manager etc just to find your POD hardware again. Then and only then can you continue to complete the de-authorization...so I did that, removed all the plug-ins, de-authorized the POD X3 Pro and the computer, as instructed.

So- did I succeed in the end? Nope .... I granted read/write permission to all possible on the Library->Application Support->POD Farm folder, then re-authorized the computer, the POD X3 Pro and the Plug-ins and POD Farm 1 still will not be authorized for use when I try it in Garageband v6.0.4 .

Note: when running the Re-authorization, I was watching the above mentioned "POD Farm" folder to see if anything got written to it- ie. change of time-stamp .. nothing did.

What next? Any more ideas?

I also checked the Line6 Manager "Diagnostics" option ..you know, this thing:

Diagnostics.jpg

... when I clicked "ok", it never opened any folder (which I guess means it generated no failure or diagnostic log at all).

Note: I did not create a "GuitarPort" folder .. as I am still wondering what exactly the relevance of that could be for authorizing POD Farm 1 with a POD X3 Pro?

Q1) when it asks you to "disconnect and re-connect the device" does that mean:

a) turn on/off the POD hardware or

b) pull out and re-insert the USB connector?

Q2) pre-authorizing, it lists POD Farm 1 and POD Farm 2 ... in the Add-ons list...

      when authorized, only POD Farm 1 is listed. How come?

Q3) In my attempts, I also got this new error once only from the License Manager app. itself (thought it might help or have some relevance) - it might have been some transient connection to Line6 server I guess(?)...

new_error.jpg

Q4) Can you please list all the possible folders that require permission changes for this to work and why an

updated version of the installer isn't coming to install all required folders with the correct permissions, so this is not something I need to consider doing manually.

Yours still hoping you can fix this (and the POD Farm 2 induced crash...)

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by apbsweden on 2011-08-06 14:47:38

Hi guys,

just to say I finally got POD Farm to say my POD X3 Pro was authorized !! ... the trick /fault was indeed

the installed permissions on Users/<Username>/Library/Application Support/Line6 folder.

I missed that this was in fact hidden, the "Users/<Username>/Library/Application Support/Line6" ..

I misread and was trying changing permissions to the visible "Macintosh HD/Library/Library/Application Support/Line6" folder. That obviously didn't help at all.

So thanks to complex69 ! Spot on... now .. any progress on my problem 2 with POD Farm 2?

/Alan



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by minyen on 2011-10-12 08:23:41

It works! Thanks complex69! Mind if I reblog it on my blog?



Re: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by trumanxvgx on 2011-12-28 03:56:55

Thanks a lot Complex69!!!

To everybody that cannot authorize pod farm on Lion follow his instuctions!



Re: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by Foxikbc on 2012-01-19 04:48:07

I've tryied everything, Licence manager doesn't see my Pod X3 live. I've installed the latest software.

And I noticed, when I turn on Monkey, at first it shows in the list: drivers, flash memory, monkey etc. but when I click on search for updates everything disappears, and the anly thing that stays is Monkey, nothing more.

So what is the metter? What shoud I do to fix this problem?



Re: RE: OSX Lion, POD Farm 1 & 2, Line 6 License Manager 1.01
by mushybun on 2012-01-21 17:05:25

I was having this issue with UX2 in garageband and this solved it.

Cheers




The information above may not be current, and you should direct questions to the current forum or review the manual.