These forums are read only, please use our new forums here.

Main :: POD HD

Support forums for all POD HD products

pod hd 300 update fail help
by rockyanez on 2011-09-23 21:03:06

i had this problem with my last pod hd  thats y i took it back and got a new one , anyways i tried updating this one and everything seemed to be going fine until it said the connection failed and now whenever i turn my POD on it says "POD HD 300 V1.31 please wait ....." then it goes blank and then it says "dsp boot fail " im kinda scared to try and update it again and mess it up even more , and yes i just reninstalled all of the soft ware , i know its not my computer because ive updated my spider 4 amp and it was fine so yeah help please, wat should i do ? maybey try a diffrent usb port ? and is there anyone i can call who can help me with this problem 

-Thanks -

rock yanez

Re: pod hd 300 update fail help
by Nick_Mattocks on 2011-09-24 08:19:38


The update has failed, but in doing so it has wiped the existing firmware from the unit, so at present it's just an expensive doorstop.  It can be reflashed, so that's what you have to do.  It's waiting for the firmware update.

You need to connect the POD to the computer directly to a USB 2.0 port and not via ANY kind of generic hub which is designed to split a USB port into two or more INCLUDING the generic hubs that are sometimes fitted internally to laptops or desktop PCs.  On a destop PC a rear  USB port is less likely to be connected through a hub where as if your PC has front USB ports then it is possible that a hub has been used in the case.

Yep try a different USB port.  It may still be something with your computer that doesn't like the HD300.

Anyhow, the way it is now means that unless you take it back or get someone else to attempt the update on their computer for you, you have no choice but to attempt the update again.


Re: pod hd 300 update fail help
by rockyanez on 2011-09-24 08:30:17

ok ill try that but wat if i update it again and it fails will it like permentally mess up the system ? and the usb port im suppose to plug into is in the back of the computer right ?

Re: pod hd 300 update fail help
by rockyanez on 2011-09-24 10:31:42

thank u very much it works now

Re: pod hd 300 update fail help
by Nick_Mattocks on 2011-09-24 10:53:52


It shouldn't permanently mess up your POD or your computer by trying again.  Yes, if given a choice i would say that your best bet is to plug into a rear USB port on a desktop computer.  You can try any of your PC's USB ports.  It was probably a MIDI communication error which stopped the update from going through.   Try a different USB cable if you have one.

Unplug any other peripherals.  Try downloading the firmware update file from the Downloads page and updating from file.

Try updating the POD whilst it's in SAFE mode or TEST mode which on the HD300 I believe might be achived by holding down the left button on the 4 way Nav Pad whilst you power on.  On the HD500 it's the right button that needs to be held down


Re: pod hd 300 update fail help
by hbotsch on 2012-07-22 02:41:44

Hi Rockyanez + Nick,

sorry for coming back to an old posting, but I have the same problem now after trying to update my HD300 to the latest firmware V2.01 yesterday. Now, when I start it, the display first shows "Pod HD300 V2.01 please wait..." and after it there comes the "DSP Boot failed" and the display changes into clear dislplay immediately. So, like I wrote before: it seems that the latest Firmware (V2.01) is on the Pod, but something else is going wrong. If I connected with my PC via USB and opening Monkey V1.58 (so also the latest version), i'll be told, that all items are up to date. I don' tknow what to do now...!   I can't find the SAFE or TEST Mode like you (Nick) wrote while press the left button (A-AMP-pro/post) on the 4 way NavPad and power on. With this combination, at my HD300 ther will start the factory restore - which I also tryed yet, but after it I get the same error with the DSP Boot Failed". Has anybody of you any other tip? Thanks in advance...!


Re: pod hd 300 update fail help
by TheRealZap on 2012-07-22 05:48:48


Re: pod hd 300 update fail help
by hbotsch on 2012-07-27 10:45:15


Re: pod hd 300 update fail help
by nagualrocker on 2012-11-24 17:53:31

help me please
i have the same problem

Re: pod hd 300 update fail help
by Tyrrellr on 2012-11-27 17:41:01

I too have this exact problem. PC quite happy about POD HD 300 - drivers all ready, up and running - but the device itself says "DSP Boot failed". Aghast - totally stuck. What now?

The information above may not be current, and you should direct questions to the current forum or review the manual.