These forums are read only, please use our new forums here.

Main :: Line 6 X2 Digital Wireless

Battery problem with XDT1
by vbiznet on 2009-05-16 08:24:59

I purchase the X2 Series Digital Wireless system on Jan 15th, 2009.  The 1st time that I used it, my sound became distorted after about 9 minutes.  I thought that I had a defective battery.  The next time that I used it it lasted about 3 songs and again the sound became distorted.  I thought that maybe I had a defective cable.  I set the rig aside and did't use it again for several months.  Last Sunday I set it up at home and attempted to use it,  Again the sound became distorted after about 3 songs.  I tried numerous batteries and each time the rig would work for about 3 songs before producing distorted, scratchy sound.


Re: Battery problem with XDT1
by talbotpat on 2009-05-18 08:37:05

The XDT1 sounds suspect given the symptoms you describe.  In my experience, using a variety of different batteries, I have never gotten a distorted or 'scratchy' sound.  Cutouts, or the XDT1 powering off altogether due to a low battery I have experienced.  My guess is that your XDT1 is defective and needs to be repaired.


Re: Battery problem with XDT1
by Line6Hugo on 2009-05-18 14:57:32

+1 to talbotpat

I would recommend contacting our customer service line to resolve this issue:

(818) 575-3600



Re: Battery problem with XDT1
by vbiznet on 2009-05-28 11:39:04

How do I check on equipment that has been sent to Line 6.  I had a RMA and the merchandise has been received by Line 6.



The information above may not be current, and you should direct questions to the current forum or review the manual.