These forums are read only, please use our new forums here.

Main :: POD X3



Poor performance using bass with Pod X3 through headphones
by fredpantalone on 2012-03-19 07:46:08

Hi folks,

Instead of writing boring paragraphs I'm going to keep this simple:

-When I play bass through the Pod X3 it often sounds terrible and flabby and I don't even hear the correct note;

-I'm suspicious of my headphones, Grado SR60@32 Ohms;

-Line 6 appears to recommend headphones @150-600 Ohms;

My questions:

-What are the symptoms of using the wrong headphones (is it what I've briefly described above)?

-If I buy something like Beyerdynamic  DT-990 Pro headphones @250 Ohms will it help?

-What is the headphone output impedance on the X3?

-Why is finding information about recommended headphone impedance and the output impedance so difficult?

Thanks!

Fred



Re: Poor performance using bass with Pod X3 through headphones
by Line6david on 2012-03-30 11:03:42

Hi,

This does sound like an impedance issue. The Beyerdynamic headphones are a good choice, I have used them on several occasions. Here is the headphone FAQ:

http://line6.com/support/docs/DOC-4695

Thanks,

David">http://line6.com/support/docs/DOC-4695">http://line6.com/support/docs/DOC-4695

Thanks,

David



Re: Poor performance using bass with Pod X3 through headphones
by fredpantalone on 2012-04-02 06:50:17

Thanks, David. If I buy those headphones (or some other high impedance model) I'll post the result here.

Fred




The information above may not be current, and you should direct questions to the current forum or review the manual.