These forums are read only, please use our new forums here.

Main :: POD HD


Support forums for all POD HD products


Recurring foot switch problems
by adamajah on 2012-05-31 13:50:50

I bought my HD400 about 11 months ago and a few months in my "A" foot switch started feeling "crunchy" when pressed and didn't always activate.  It got worse so I had it repaired under warranty at a local shop.  It worked great for another few months but now it's getting bad again.  I've got one month left on the warranty and will be taking it in to get "fixed" again. 

I'm wondering if anyone else is having this problem and if it's common? 

I could also use advice on what to do a few months from now when it most likely will stop working properly again and it's not under warranty.  I use this thing pretty gently in my man cave at home, so this is pretty disappointing.  Is it possible the repair center I take it to doesn't know how to fix it right, and I need ot send it in to Line 6?

Thanks



Re: Recurring foot switch problems
by jimsreynolds on 2012-05-31 21:44:10

Wondering if it actually got fixed the first time or whether they just hit it with a bunch of lube spray.   Take it back again and check who they are getting the unit repaired by.   I dont recall seeing anyone reporting this issue before ... could be wrong.



Re: Recurring foot switch problems
by Cabhater on 2012-05-31 23:03:37

I had the same problem on my HD300. I sent the device to the service. It is a frequent defect. Weak, low-cost switches. That's all.



Re: Recurring foot switch problems
by fenderst1 on 2012-06-03 11:46:48

I would think that you have the same setup as in the HD500..tactile switches. My hd500 was giving me problems so I decided to fix and get rid of the tiny tactile switches. If your out of warranty its a very rugged long time fix, and replacing heavy duty swithches is very easy once you convert your unit.DSCF0004.JPG




The information above may not be current, and you should direct questions to the current forum or review the manual.