These forums are read only, please use our new forums here.

Main :: James Tyler Variax Guitars


Support community for JTV.


Help with JTV 69, extremely agitated...
by sanctuaryofsoul on 2012-06-19 08:41:26

SO

Yesterday at a gig I went to move my model selector knob and the tip came off.  For a 1499 guitar this is upsetting, does anyone have any recommendations as to how to fix.  There seems to be no ahesive bond so should I put some super glue and put it in myself.  Or, is this beyond me and without risking voiding a warranty should I take it to a L6 warranty location.



Re: Help with JTV 69, extremely agitated...
by player99 on 2012-06-19 15:52:32

Mine did that the other day as well. The metal part just fell right off. It still works with out it. Actually makes the guitar lighter. :-)



Re: Help with JTV 69, extremely agitated...
by tomt6257 on 2012-08-18 08:20:36

I had the same thing happen.  I have only played the guitar 5 times. It doesn appear to be any way other than glue to get it to stick.



Re: Help with JTV 69, extremely agitated...
by player99 on 2012-08-18 12:52:26

Mine did the same thing. If you glue it watch out you don't get glue or thumb prints on the pickguard.



Re: Help with JTV 69, extremely agitated...
by toasterdude on 2012-08-19 19:00:33

Hmmm. . .I hate the way the stock gold looking knob covers and rings look on my new xplants. I was going to look into ordering a chorme model selector knob froma service center. Unfortunately they don't have a chrome tuning selection knob. I may have to go black for that. Thats sucks.

Now that I know how easy they fall off. . .I sort of hope mine do. . .so I can look at gluing on a chrome, or pearloid type replacement.




The information above may not be current, and you should direct questions to the current forum or review the manual.