These forums are read only, please use our new forums here.

Main :: James Tyler Variax Guitars


Support community for JTV.


james tyler jtv 69 variax problem
by broker2 on 2012-06-26 11:14:49

i just picked up my james tyler jtv 69  made in korea awesome right out of the box plugged it in the pickups sound awesome push the model knob and all models work fine all tunings work fine but i have too power down and than power back up again too get back too the regular pickups  is this normal.i love this guitar    thank you for all your help   cal



Re: james tyler jtv 69 variax problem
by player99 on 2012-06-26 15:45:17

You may have the model knob problem. If you pull it off and stuff something in to keep the shaft from going down too low it might fix your problem.



Re: james tyler jtv 69 variax problem
by broker2 on 2012-06-30 15:34:56

thank you player99 for your advice but i jumped the gun on this i tried the jtv69 today and everything works fine i just touch the model knob the model lights come on everything works push it again and im back too normal . so everything works fine  thanks    cal



Re: james tyler jtv 69 variax problem
by XCrossroadsX2000 on 2012-07-01 10:24:14

Yes you have to power down by pressing on the knob to shut the piezo pickup off and turn the magnetic pickups on.

You can only have one or the other, which means you can only use the open tunings in modeling mode, not with the standard pickups.




The information above may not be current, and you should direct questions to the current forum or review the manual.