These forums are read only, please use our new forums here.

Main :: POD HD


Support forums for all POD HD products


HD300 - Tap/Tuner switch sticking - fix?
by tomhyzy on 2012-07-10 06:57:05

Recently, when I dis-engage the tuner on my HD300, the unit will "slip" back into tuner mode by itself.  This appears to be some kind of sticky switch problem with the tap/tuner switch.  If I press that switch a few more times, the unit will stay in normal "play" mode, but it's annoying.  The unit has not seen heavy use, I've owned it for about 1.5 years and it has mostly been in my basement music room.  Has anyone else encountered this issue, and has anyone got a fix for it?  I appreciate help on this, thanks.



Re: HD300 - Tap/Tuner switch sticking - fix?
by mazuwa on 2012-07-10 07:32:04

You should bring it to a service center, sorry. For further help take a look at the line6 homepage under "Support" -> "Customer Service" like this:

http://line6.com/support/docs/DOC-1606">http://line6.com/support/docs/DOC-1606">http://line6.com/support/docs/DOC-1606. This will result in a relieable device / piece of work.

It may have a sticky switch problem, but also may have a contact problem to the circuit board, or somehow gets a short circuit.

Only if guarantee is over and you have experience with electronics / soldering etc, you may try to open the case and have a look inside and resolder / do some isolation. But even if you discover the problem - you might need and do not have replacement parts.



Re: HD300 - Tap/Tuner switch sticking - fix?
by nicman on 2012-07-11 20:26:33

yeah thats a technical problem needing to be fixed




The information above may not be current, and you should direct questions to the current forum or review the manual.