These forums are read only, please use our new forums here.

Main :: Relay Digital Wireless



G50 Relay - TBP12 Transmitter adding LOADS of noise of the signal!
by FarleyUK on 2012-09-30 03:37:03

Hi all,

I just purchased a G50 Relay system, and have discovered that the transmitter is adding a metric crap-ton of noise and buzzing into my signal! I've tried the whole setup with just the guitrar via cable to amp - that's fine. Then I tried the receiver to the amp via the same cable - no noise, so that's fine. Then I plugged in the transmitter to the guitar, and there is a LOAD of buzzing, at all ranges.

I've tried all channels, power save mode etc., and nothing stops it. I have noticed that if I place my hand over the aerial on the transmitter though that the buzzing reduces dramatically.

Has anyone got any ideas how to stop this? As far as I'm concerned, it's unuseable in the current state - it really is that bad!!



Re: G50 Relay - TBP12 Transmitter adding LOADS of noise of the signal!
by dboomer on 2012-09-30 09:32:10

Hi Farley

If you unplug from the transmitter do you still get the noise?

How about if you leave the cable in the transmitter but short across the tip and sleeve?

Have yo tried it with more than one instrument?

Is your instrument active?

Does the noise change as you change cable models?



Re: G50 Relay - TBP12 Transmitter adding LOADS of noise of the signal!
by FarleyUK on 2012-09-30 12:39:52

Hi,

Cheers for the response:

If you unplug from the transmitter do you still get the noise?

Yes - it happens whether the guitar is plugged in or not.

How about if you leave the cable in the transmitter but short across the tip and sleeve?

No difference.

Have yo tried it with more than one instrument?

No - I only have one guitar.

Is your instrument active?

Er, not sure - I'm running the Alnico 2 Pro Slash pickups though!

Does the noise change as you change cable models?

Nope, no change.



Re: G50 Relay - TBP12 Transmitter adding LOADS of noise of the signal!
by FarleyUK on 2012-10-02 07:27:31

UPDATE: The original retailer is sending me another whole unit tomorrow, so I'll test it out and report back. I'm seriously hoping that solves the issue, as from my discussions with other users, there's no way it should be adding any noise to the signal at all!



Re: G50 Relay - TBP12 Transmitter adding LOADS of noise of the signal!
by line6jonb on 2012-10-02 17:14:33

No the transmitter definitely should not be adding any noise to the signal at all.  Please let us know how your replacement G50 system works out when you receive it. 




The information above may not be current, and you should direct questions to the current forum or review the manual.