These forums are read only, please use our new forums here.

Main :: DT50/DT25



DT25 - Loud, random pops and crackles???
by rsto10 on 2012-11-19 15:00:47

I own both a DT50 (112) and DT25 (112).  Have never experienced anything like this with my DT50 (which gets most of the use), but lately my DT25 has been popping and crackling randomly.  This amp is my secondary amp and has not been used all that much since purchase in February.  Anyone else experience this with their amp and if so, is there an easy solution or is this a warranty issue?  Thanks!



Re: DT25 - Loud, random pops and crackles???
by Rowbi on 2012-11-19 15:07:50

It could be tubes.  Try reseating them or having a tech fit new ones.  If that doesn't resolve then I suggest a warranty call.

Rowbi



Re: DT25 - Loud, random pops and crackles???
by chrisolson68 on 2012-11-20 06:21:26

Yep, I'd agree.  Either a tube or something your friendly service guy will need to look into.



Re: DT25 - Loud, random pops and crackles???
by gregorydileo on 2012-11-25 06:08:44

I've got the same problem with my DT25.  It's definitely the tubes.  I've reseated them with no help.  I've seen this issue on other threads that recommended replacing the tubes (Mine are Electro Harmonix  EL84EHs, made in Russia) with another compatible kind that fixed the problem, but this amp is new (less than 90 days) and I don't want to pay to fix a defect in manufacturing.  Before I go there, can anyone share a better tube that will work with the DT25 combo?



Re: DT25 - Loud, random pops and crackles???
by Hummelong on 2012-11-26 10:50:00

My DT25-112 recently started making weird noises.  Kind of like somebody crumpling a sheet of paper under a blanket...I took it all apart, reseated the tubes, cleaned jacks and connectors. tapped everything with a plastic chopstick.  Couldn't figure out what it was.

I had replaced the power tubes earlier in the year when one of them started acting up.  This time I tried replacing the phase inverter tube (the only 12AX7 in a DT25) and the problem went away!

The original tube in my amp had no brand, it just said 12AX7 / China.  I replaced it with a Sovtek 12AX7 and it sounds just fine.  Because this isn't a preamp stage, it doesn't have to be a perfect tube, but sometimes tubes can get noisy.

If you have a spare 12AX7 lying around it doesn't hurt to give it a try.

HTH

Mike




The information above may not be current, and you should direct questions to the current forum or review the manual.