These forums are read only, please use our new forums here.

Main :: POD HD


Support forums for all POD HD products


Direct recording into Garageband?
by kahawe on 2012-11-25 12:44:58

I have a POD HD400 that I plugged into USB and I am trying to record it into Garageband 11 (6.0.5) on OSX 10.8.2; my POD's firmware, it's drivers and Monkey are ALL uptodate, Monkey tells me so.

- I create a new "real instrument" track in Garageband and then I am wondering, which source of the HOD400 should I select? It offers me 2 Mono sources (Mono 1 and Mono 2) and one stereo source of the HD400. What's the difference between the three? One "Mono" is much quieter than the other. I tried the stereo source but the guitar is pretty panned to one side?

- Is it correct that while recording, I HAVE to select the HD400 as Input AND Output? So I plug my headphones into the HD400 and monitor with it?

- While recording from stereo 1/2 I had an issue with the signal very shortly disappearing in the recorded track and it made a popping sound and then worked fine again; I know for sure that was not my guitar, it sounded like the modelling shortly stopping or so? Should I increase the buffer, maybe my CPU was too slow? (currently buffers are set to smallest, most cpu usage)

- Generally, should I set the "Recording Level" in Garageband for that track to 100% or what??? (Otherwise it is really very, very quiet... but I am worrying about clipping)

Is direct-recording via USB like that the preferred method? Or would other ways of recording it giving me better quality?

Last but not least, is there any tutorial for USB/direct recording the POD HD into Garageband or Logic or whatever? Written or youtube video or a manual or anything? I feel very lost... and would be happy for a beginner's tutorial with the best practices for all those settings.



Re: Direct recording into Garageband?
by GTLazer on 2012-11-26 03:31:03

My recording experience is fairly limited, and I mostly use Ableton and an HD500, but I'll see what I can do.

First, mono 1 and mono 2 are just the two channels of the stereo feed, so your 'panned' stereo sound is caused by the volume difference in your mono channels. Check the mixer settings in your HD400 patch or your input levels in GB.

Second, yes you're right to use the HD400 as In and Out. This means you can live monitor your guitar playing, so you don't hear the delay caused by the latency in GB. As long as you've set up GB properly, it should compensate for the latency in the recording.

Third, that does sound like you need to increase the buffer size to prevent the popping. Doing so will increase the latency but, again, as long as this is set up correctly and you're using live monitoring, it shouldn't be a problem.

Fourth, I'm not sure about the recording levels, but people on here have said that recording is generally better (certainly for the HD500) with the master volume set high, then adjust the levels on your audio track in GB to something you're happy with. It's always worth remembering that you can play a short section into the HD400's looper, then leave that playing while you adjust the levels in GB.

Fifth, my intention is to get a firewire interface at some point (mostly for additional I/O for other equipment), but in the meantime I'm more than happy with the HD500's USB interface, which runs into my laptop and Ableton with almost zero latency.

And finally, if you're anything like me, YouTube will definitely be your friend. I've picked up loads of useful Ableton stuff from there so I can only assume that the same will apply to GB/Logic.

Hopefully you can find your way from there, but perhaps someone on here who actually uses GB might be able to help further.



Re: Direct recording into Garageband?
by kahawe on 2012-11-26 16:04:28

Thankyou for the hints and suggestions!

Concerning the buffers, how do I know that I should increase them and by how much? I don't notice any latency while recording but I am monitoring via the hd400 anyway.

Also, on the "Line6 Audio-MIDI Devices" preferences page it tells me something like "Sample Rate Converter Active" but it doesn't seem to be active, the LED is red, the garageband project is set to 44.1kHz - the inputs and outputs of hd400 in OSX's audio-midi-setup: 44100Hz 2ch 24bit.

BUT Garageband is recording at 16bit... could this be a problem?



Re: Direct recording into Garageband?
by kahawe on 2012-11-28 08:36:30

Anyone?



Re: Direct recording into Garageband?
by GTLazer on 2012-11-30 00:47:30

In Ableton there's a bit in the audio setup where you can switch on a test tone, and adjust what CPU useage it simulates, in order to set the buffers at the lowest possible level without getting any weird noises (if you make the buffers too small you'll see what I mean). I did that with mine and then had to go back and increase the sizes slightly further again after getting some artifacts when messing about with a soft synth.

I don't know if GB has a test tone or not, but it's worth a look. Otherwise, you could record something into the looper and monitor it through GB; that way you should be able to hear if you're getting any latency problems.



Re: Direct recording into Garageband?
by florianb5 on 2013-04-14 00:25:47

In Garageband, go to Prefences, Audio/Midi and change your Output to "built in Output", this way you can hear your guitar through your monitor or headphone with the other tracks.




The information above may not be current, and you should direct questions to the current forum or review the manual.