These forums are read only, please use our new forums here.

Main :: Stompbox Modelers / ToneCore



Major complaint on Line6 DL4 pedals.
by Numelsaince on 2012-12-28 09:21:48

Alright I want to know who else have had these kind of issues and what should we do as paying customers.

First off, I have already owned 6 of these pedals, all with an avergage life span of three months and I've had it, really, I don't know what else to do, no other pedal does what this one does at a stop-box scale, offering 3 presets of delay settings, a loop function and double speed/half speed modulation.


These pedals have had a reputation of being faulty as this video shows: http://www.youtube.com/watch?v=DJ4TBQGgqPE">http://www.youtube.com/watch?v=DJ4TBQGgqPE">http://www.youtube.com/watch?v=DJ4TBQGgqPE

Other pedals that might be more reliable, or offer the same function are more expensive, like the echoplex or looperative racks. About $1000 a piece.

What should we do? I'm definitely changing brands, I know I should have learned my lesson from the start but I had faith it was just a power issue, but now I got these 6+ boxes of scrap metal laying around.

So what are your thoughts about this? I'm interested in hearing about owners having the same issues, or are enraged just as I am.

P.S: Here's a video that shows how I use this pedal:http://www.youtube.com/watch?v=RkWip77O9Yk">http://www.youtube.com/watch?v=RkWip77O9Yk">http://www.youtube.com/watch?v=RkWip77O9Yk

I hope someone can enlight me.




The information above may not be current, and you should direct questions to the current forum or review the manual.