These forums are read only, please use our new forums here.

Main :: James Tyler Variax Guitars


Support community for JTV.


JTV - Acoustic Models sounded Treble
by archisc on 2013-01-17 10:30:54

I just received my jtv 59. Upgraded to 1.90. However, I found all of my acoustic models sounded with high treble. I plug it into my fender acoustic amp, I need to dial bass2, middle 2, treble 2.. but still the results sounds treble..... I have an ovation LX and a high end taylor and none of them require this kind of settings. When I use podhd, with eq, through headphones, I hear high treble too..

Is this normal? Anyone else have the same problem?

The bass boom can be heavy with you strum hard too...



Re: JTV - Acoustic Models sounded Treble
by SliderJack on 2013-01-18 12:37:48

Have you tried various acoustic models? I don't have an acoustic amp but agree it can sound very bright through my Pod and DT50. I get best results running mine through my pod500 with a stereo acoustic patch and into my PA. Then I get a nice warm/full tone.



Re: JTV - Acoustic Models sounded Treble
by phil_m on 2013-01-18 13:04:40

One thing to remember is that the acoustic models on the Variax are modeling the sound of miced acoustic guitar, and that typically sounds quite different than what you hear coming from an undersaddle transducer and preamp system on an acoustic-electric guitar.




The information above may not be current, and you should direct questions to the current forum or review the manual.