These forums are read only, please use our new forums here.

Main :: POD X3



Emergency help needed X3 PRO
by ninthaspect on 2013-01-18 14:04:19

My Pod X3 Pro was working fine last night. Tried to turn it on just now and there is nothing happening, no power at all, I have checked the fuse in the plug and it seems ok, I have even tried another lead which i know is fine and nothing happening, no lights or any signs of power. There is a small slow blow fuse 1.25 amp inside on mother board, has anyone had this type of problem and is it common for the internal fuse to blow. I could understand if it went of while i was using it but seems strange to suddenly just not power up at all.

Anyone any ideas or suggestions, had no problems with it up to this point, only had it a few weeks but its was bought second hand with very few hours use?

HELP!



Re: Emergency help needed X3 PRO
by ninthaspect on 2013-01-18 15:06:55

Internal fuse 1.25 amp 250v has gone, must of been a power surge or something, replaced it with a 2.5 to test and worked fine, will turn off until i can get correct fuse.

Thankyou

This would of cost me shipping both ways to a service centre and then minimum labour cost plus parts. Fuse is about 60 pence!




The information above may not be current, and you should direct questions to the current forum or review the manual.