These forums are read only, please use our new forums here.

Main :: Relay Digital Wireless



G50 and acoustic = interference/noise?
by AHoddy on 2013-02-16 11:18:50

Good evening!

I've recently purchased the G50 and it works wonders on my Fender Strat and Jazz Bass. However, when I plug it into my Gibson J150 electro acoustic, there is an awful amount of noise/interference. So much so that it makes it unplayable. Anyone have a similar issue at all? Any suggestions on how to fix it?

Many thanks

Ahoddy



Re: G50 and acoustic = interference/noise?
by dboomer on 2013-02-16 11:44:40

Does your Gibson have a built-in preamp?  If so your preamp may not be shielded to RF.  To test it try using a 20 foot cable between your guitar and the transmitter.  Then move the transmitter as far away as you can.  Does the noise go down?  If so you will need to shield your preamp.



Re: G50 and acoustic = interference/noise?
by AHoddy on 2013-02-17 10:13:02

Hi dboomer

Thanks for your reply. Just wondering how I go about doing that if the transmitter has the 4pin connector on the unit ie: jack to 4pin, not jack to jack.

My Gibby has an "active" pickup according to gibson, which requires a  battery if that's any use?



Re: G50 and acoustic = interference/noise?
by dboomer on 2013-02-18 14:36:12

You could use a double female barrel or you could use wire with allegator clips.

Actually just try unpluging the transmitter from the guitar and plug in the guitar in direct with a cable.  Now with the transmitter still turned on and a cable inserted in it get it near your guitar. You won't even need the receiver at this point.

Do you hear the noise come up?  I suspect you will as the built-in preamp is not RF resistant.




The information above may not be current, and you should direct questions to the current forum or review the manual.