Jump to content

612 topics in this forum

  1. X3 Pro - volume problem

    • 0 replies
    • 447 views
    • 0 replies
    • 407 views
  2. Problem with pedal and sound output: POD X3 Live

    • 3 replies
    • 910 views
    • 0 replies
    • 556 views
    • 2 replies
    • 515 views
  3. Podx3 And Looper Pedal?

    • 6 replies
    • 3,197 views
    • 3 replies
    • 710 views
    • 47 replies
    • 40,072 views
    • 10 replies
    • 6,172 views
    • 0 replies
    • 512 views
    • 2 replies
    • 677 views
    • 5 replies
    • 1,198 views
  4. Used line 6 pod3xlive

    • 2 replies
    • 615 views
  5. Pod x3 pro rebooting

    • 0 replies
    • 555 views
    • 5 replies
    • 3,411 views
    • 3 replies
    • 827 views
    • 2 replies
    • 610 views
    • 1 reply
    • 495 views
  6. Connection

    • 4 replies
    • 811 views
    • 0 replies
    • 468 views
    • 6 replies
    • 627 views
  7. wah too loud

    • 3 replies
    • 2,466 views
    • 3 replies
    • 978 views
    • 10 replies
    • 1,524 views
    • 0 replies
    • 968 views
    • 5 replies
    • 735 views
    • 0 replies
    • 539 views
    • 28 replies
    • 4,692 views
    • 3 replies
    • 827 views
    • 8 replies
    • 2,766 views
  8. Weird...

    • 3 replies
    • 806 views
  9. POD X3 live uses

    • 1 reply
    • 674 views
    • 1 reply
    • 676 views
  10. POD X3 live Crazy

    • 0 replies
    • 668 views
    • 0 replies
    • 477 views
  11. x3 dual tones

    • 1 reply
    • 670 views
    • 1 reply
    • 707 views
    • 2 replies
    • 723 views
    • 0 replies
    • 563 views
    • 1 reply
    • 572 views
  12. Replacement X3 Live

    • 2 replies
    • 1,183 views
    • 0 replies
    • 579 views
  13. USB MIDI

    • 1 reply
    • 995 views
    • 0 replies
    • 1,218 views
  14. X3 Pro resetting

    • 5 replies
    • 771 views
    • 1 reply
    • 822 views
    • 11 replies
    • 3,784 views
    • 15 replies
    • 1,251 views
    • 1 reply
    • 1,143 views
    • 6 replies
    • 713 views
×