Jump to content
quimbie

X3 Live with Windows 8.1, issues w/ Riffworks/Guitar Pro

Recommended Posts

Hello,

 

My laptop finally died after 8 years. I broke down and got a new one two days ago.  Problem is it is loaded with Windows 8.1.  Gear Box and Line 6 Monkey seem to be alright, but I cannot get the new Riffworks Standard to work with it. I downloaded ASIO 4ALL and that didn't help.  I then tried to play along with Guitar Pro 5 and that wouldn't play through my headphones on the X3 Live either. So, I am stuck. On my last laptop I would write songs using Riffworks along with my X3 Live.  I would have my guitar plugged into the X3 Live and listen through my headphones, using Windows 7. I am getting no sign of any input on Riffworks Standard. and Guitar Pro will not play through my headphones either. Both programs work through the laptop speakers on their own but do not recognize my X3 Live at all. I very much enjoy both programs and use them pretty much daily. How can I get these programs to work with my X3 Live?  HELP !!!!   TIA

 

Thank You

Share this post


Link to post
Share on other sites

I fixed it.....You won't believe this guys but this is how I fixed it.

 

1.   Downloaded the most recent drivers through the Line 6 Monkey. Already had the most recent but I reinstalled them anyway.

 

2.   Tried all 4 USB ports on my laptop. 3 USB ports did not work.  There was one USB port on the other side of the computer off on it's own. 

 

I plugged into that one and it finally recognized it.  It also worked with my Guitar Pro 6 program as well.  It took 2 days, but I am up and

 

working well. 

 

I hope this helps others.

 

Thank You,

 

AZ

  • Upvote 1

Share this post


Link to post
Share on other sites

I have a problem when is needed to connect my POD X3 Live on my notebook, i'm using OS Windows 8.1 Pro 64Bits, and simply I can't connect my POD! the hardware is undetectable and the Monkey can't install the drivers I need, or if I download from the line6 website, after all the install process, the Monkey still accuses that the driver isn't in my notebook?

 

Somebody could help?

 

(sorry for the weird text, i'm not good with English)

 

Peace!

Share this post


Link to post
Share on other sites

Thiago, try this

1. Go to the Line 6 website and download the latest drivers.

2. Without the Pod plugged in, install your drivers.

3. Restart your computer after installation.

4. Now plug in your Pod to the computer.

5. Open the Monkey and log in.

6. Wait for the program to recognize your Pod.

7. If it does not, try a different USB port.

8. If it still doesn't recognize your Pod, then install the next newest driver version.

 

I experienced times when the newest driver didn't work but the older did.

 

Good Luck. AZ

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...