Jump to content
Sign in to follow this  
markus506

DT25 2.0 update brighter/louder?

Recommended Posts

Hi everyone,

 

I may be losing my mind, but it seems that my dt25, after updating to 2.0 (7 tries :( ) is a bit louder and a lot brighter/harsher than before. Is this even possible? I run it using an HD500 using L6 link. I was pretty happy with my tones before the update but I'm struggling to dial things back in. Did anything, other than the ability to change preamps/cabs/etc change that could cause this? I could switch back to 1.0 and check things out, but it was such a challenge to update I don't want to try it again :(

 

 

Thanks!

Share this post


Link to post
Share on other sites

its been so long since I updated that I really don't remember... off hand I can't say I heard anything different.  As a matter of fact, after putting the DT to the side to build PA tones for a few months I just started using it again.  I have to say, my tones now are better than ever and I absolutely love this rig... If you really need to dial it back in, go for it...

Share this post


Link to post
Share on other sites

its been so long since I updated that I really don't remember... off hand I can't say I heard anything different.  As a matter of fact, after putting the DT to the side to build PA tones for a few months I just started using it again.  I have to say, my tones now are better than ever and I absolutely love this rig... If you really need to dial it back in, go for it...

I guess I'll have to do just that. I am just finding that before the update, it was easier to dial in. I find it a bit trickier now, as everything just sounds harsher. It's probably just me, and nothing changed that could actually cause it to be brighter. lol. 

Share this post


Link to post
Share on other sites

Unrelated, but possible ... your tubes may show signs of aging or failing.

I thought about doing this regardless. Perhaps looking at some JJ's may fit the bill. Thanks for the suggestion :)

 

 

Topology choices may have changed in your presets.

 

Hmm...I didn't look at this, assuming the HD500 patches stayed the same. I will check tonight, just to make sure. Thanks!

 

I am also going to try the 'Jay Mitchell Doughnut' piece of foam to see if I can tame the piercing highs. I'll report back if I get around to this.

 

 

-Mark

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×