Please ensure Javascript is enabled for purposes of website accessibility Jump to content

What's happened with this amp!!?


Recommended Posts


I bought a Amplifi 150 but since 4 days now i've a lot of problem!


1- Can't connect to my account on my ipad air (i tried several times!!!) just impossible say: "Failed to log into"

The bluetooth work.


2- On Android 4.4 device with Sony Z2 i can log to my account but can't see my amplifi in the app ^^


3- On my PC when i open utility i've this message "No Amplifi Devices were detected"


I think it's just to much to take on, do you think there is some solution or i have to take something else?




Link to comment
Share on other sites

Hmmm... You're definitely justified in feeling frustrated!


Do you know what firmware you're running on the amp? If you can get the USB installer to work, that's probably what I'd focus on first. Have you tried different USB cables? Does the Amplifi show up on your computer at all when you connect it via USB?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...