Jump to content
Coldplayplayer

Recording with Sonic Port Vx and Pod Farm 2 problem.

Recommended Posts

Hi there all from New Zealand. I've got a sonic port vx connected to my macbook air. I use REAPER as my DAW. When I fire up POD FARM I can hear the processed sound for the patch selected. When in REAPER and recording, you can hear the processed sound. When I play back the track after recording, it is a dry signal, i.e. not what you are hearing from within POD FARM or when recording the track. 

 

Does anyone have an idea of why this may be happening. I am using the trail version of POD FARM and don't want to spend the money buying a license if I won't be able to record processed signals within REAPER. I have had no problems with my POD HD500 or previously with my UX2. So I'm assuming the sonic port vx should be used the same way and I can't work out why it isn't recording the processed signal from POD FARM.

 

Hopefully this makes sense and thanks in advance for anyone who may have a solution.

Share this post


Link to post
Share on other sites

I think the problem may be your Record Input settings. Pod Farm supports recording the dry and/or wet signal. Sounds like your current settings select the Dry option. I think you will find these settings in the Pod Farm Mixer window, and/or in Reaper associated with arming a track for recording.

Share this post


Link to post
Share on other sites

Silverhead,

 

thanks for the reply. I can't see anywhere in Pod Farm Mixer window (or any of the other windows/tabs in pod farm) to select sending either wet or dry signal. I've tried also in Reaper but it either still records the dry signal or doesn't receive any audio input at all.

 

If it helps, I'm using Pod Farm 2.58 (Trial Version) on a Macbook Air with my Sonic Port VX selected as the Input and Output device. In Reaper, Sonic Port VX is selected as the input and output device also. 

 

Not sure what else to do the moment. If you've got anymore ideas, I'd like to hear them. 

Share this post


Link to post
Share on other sites

I'm not a Mac guy but I expect if you go into Preferences or Settings for audio in general or the SP in particular you might find some settings that could be adjusted. Other than that, I'll bow out here and let Mac experienced users jump in.

Share this post


Link to post
Share on other sites

Silverhead, thanks. I've fixed the problem. Out of curiosity, I installed Sonic Port VX drivers on my windows pc, installed POD FARM 2 trail version as well and then fired up REAPER. I had some big problems with both POD FARM and REAPER open where the Sonic Port VX would be disabled as well as my CASIO Digital Piano. When I closed POD FARM 2 running standalone the Sonic Port VX and Casio Keyboard would come back to life within REAPER. 

 

So the next thing I tried was to add POD FARM 2 as a VST in Reaper and that was when I noticed in the POD FARM 2 mixer window a drop down to select the input device. Once I selected Sonic Port VX in the input drop down, I had no problems recording the wet signal.

 

I just went to my Mac, fired up REAPER, added POD FARM 2 as a VST on a track and was able to select Sonic Port VX as an input and then record the wet signal.

 

So with your help and a bit of trouble shooting, my problem is fixed.

 

In précis, the solution for me is don't run POD FARM standalone when recording with REAPER. Instead, add it as a VST on a track and then select the input within the POD FARM mixer window.

 

Next step, buy a POD FARM 2 license  :) and make more music.

Share this post


Link to post
Share on other sites

I used to have great low latency recording with Pod Farm and my Toneport GX. Using my new Sonic Port VX with Pod Farm as a VST plugin (in Reaper) doesn't work so well, as you don't get the hardware monitoring.

 

What I really want to do is what the original poster was trying to do: run Pod Farm standalone with my Sonic Port VX, and capture the output of Pod Farm (rather than the dry signal) in my DAW. Is this actually possible? I'm using the latest version of Pod Farm on a Mac running Yosemite; I can't find any combination of options in Pod Farm or Reaper that will enable Reaper to capture the standalone Pod Farm's output.

Share this post


Link to post
Share on other sites

as long as you paid for a pod farm license independently you can do this....

if you only have the license that came with your GX, no.

Share this post


Link to post
Share on other sites

just launch from the icon, you may need to go into the settings and select your interface.

Share this post


Link to post
Share on other sites

I don't have a problem launching Pod Farm, and hearing the processed signal through the Sonic Port's output; I have a problem capturing that processed signal in my DAW. All I can seem to record is the dry signal.

Share this post


Link to post
Share on other sites

It would also be useful to be able to capture the processed signal from Sonic Port VX via Pod Farm into other software, such as the Mac Photo Booth software, for live video recording purposes.

Share this post


Link to post
Share on other sites

Can anyone tell me how to make the Sonic Port VX the out pit audio for my MAC?I can't figure out how to get all my audio to come thru my monitors,iTunes,etc..

Share this post


Link to post
Share on other sites

For the time being I've settled for low-latency monitoring via a standalone POD Farm instance, capturing the dry signal, and applying the same POD Farm effects via the VST plugin in the DAW. This has the advantage that I can re-amp post recording if I wish, but it's still a slight roadbump in the workflow I'm used to.

Share this post


Link to post
Share on other sites

I have a question to the OP and others who use the VX with a PC/mac - When I use Podfarm a get a slapback effect (latency is the word?) in the VST and standalone, even with the buffer at the lowest setting. When I use amplitube I don't have latency issues, but every dirt pedal makes a huge volume boost and barely any actual overdrive (I am recording the wet signal, already checked that).

 

Any ideas? Or maybe you had similar issues?

Share this post


Link to post
Share on other sites

sounds like you might have monitoring enabled when you're recording.

Share this post


Link to post
Share on other sites

Well yes, I need to hear what I'm playing. Unless I'm doing something wrong? I'm monitoring the output.

Share this post


Link to post
Share on other sites

when recording you don't need to monitor the input... since you'll hear that anyway.... doing so doubles up the sound and adds that slapback.

 

of course you want to monitor the output... its just the input you want to turn monitoring off on the track you are recording.

Share this post


Link to post
Share on other sites

All right, I'll make sure that I'm only monitoring the output, though I remember that's what I'm doing.

What do you mean when you say "you'll hear that anyway"? How can I hear something if the monitoring is disabled?

Share this post


Link to post
Share on other sites

because you'll hear the input... enabling input monitoring allows you to hear the recording.. which of course will be a little out of time with the output.

Share this post


Link to post
Share on other sites

Well, I just checked and I'm monitoring the output, not input and there's still a delay. Also, I'm not REALLY recording - I just hit "play" and jam along the backing track in Reaper. I'll try opening a ticket.

Thanks for your help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...