Jump to content
Sign in to follow this  
Dano78

L2T starts limiting after few seconds (overheating?)

Recommended Posts

Hi,
I bought a brand-new L2T, unpacked it tonight and off course testing.
But it starts limiting with a red light after approx. 20-30 seconds.

No matter which input I use or which instrument. I tried an acoustic guitar on channel 1, gain half way, master volume of L2T half way, limit starts and doesn't stop anymore, no sound is comming out of the speaker. Only the noise of the fan.
Tried 2nd. channel with a mic., same story.
Tried the red/white RCA at the back with an electronic drumkit, same story.

The fan starts and there's no sound anymore. Tried the noise suppressing on/off.

Am I overlooking something or is this one from the mondaymorning-production batch? Oh boy oh boy.

Share this post


Link to post
Share on other sites

Seems there are still issues with these things...mine arrived a month ago, only to have the dreaded fan rattle at stage volume. Currently being repaired with new fan assembly...so we'll see.

 

If/when you get it working, make sure you crank it and listen for the jack-hammer sound. Might have more than one problem lurking in there. Good luck.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...