Jump to content
tomtheguitarguy

Feedback Suppression on L2t

Recommended Posts

So lately I've been taking my L2t instead of my Bose Compact for my Duo show.  I plug my Bose T1 mixer into the back of the L2t and everything sounds great!  But....

 

The Feedback Suppression doesn't seem to work.  The last couple of shows, I've experienced some feedback and the L2t doesn't seem to notch it out.  Is there a specific procedure I should follow?  I was under the impression that it would be automatic - within a few seconds, but the feedback will continue for quite a while (I intentionally kept it going to see if all it took was a little more time than I was expecting).

 

Any ideas?

 

Thanks in advance!

 

Tom

 

Share this post


Link to post
Share on other sites

What colour is the feedback suppression pilot light?  In my experience the feedback should have been notched it out once it sustained for a bit.  I may be off on this but as far as I know the feedback suppression pilot light colour kind of corresponds to type on the M20d. So red would be the most aggressive and meant for vocals.  The lighter settings, Green and Yellow, are less aggressive and you would use those if you find your filtering out things that you don't want to like a synth note that is sustaining and misinterpreted as feedback. 

 

Of course I have somewhat approached this backwards and in most cases you should start with the Green and increase if it's not filtering the feedback enough, but I explained it this was since it may be a possibility that you are already on one of the lighter settings and need something more aggressive.  If it's already on red and not filtering out the feedback, I have no idea what it could be.

  • Upvote 1

Share this post


Link to post
Share on other sites

I may of course be totally misguided in this (I only own L3m's not t's) but I understood that the feedback suppression is only applied to the two side panel mixer based inputs and is not applied to the back panel main input. If you're plugging your tonematch into the main input, this would explain why the FBS doesn't function.

Share this post


Link to post
Share on other sites

I assume that Tom is plugging into the back (power amp module) as he is using an external mixer.  I would recommend setting the feedback button to green for music otherwise you will probably hear some artifacts that sound like clicking.

 

The Feedback manager in both Stagescape and Stagesource work to tame the frequency peaks in the system (mic/mixer/speakers) and have a limit as to how much protection they will provide.  Typically they will make the situation 2-4 times better that without.  But once you cross that line you will experience feedback again.

 

The best thing you can do for free to prevent feedback is to sing and play very close to your mics (within 1 inch).   This is because when you are very close to your mic you won't need as much "gain" in the channel to get the volume you require.  And anytime you double the distance to your mic you lose 6 dB of potential gain before feedback.  So if you move from 1" to 2" away from your mic you will increase your chances for feedback times 4.  Likewise moving from 1" to 1/2" will give you 4 times improvement.  Don't be afraid to put your lips right on the windscreen.

 

Also I should point out that the likelihood of getting feedback is inversely proportional to the size of your venue (especially with respect to ceiling hight).  This is pretty self evident when you think about your own experiences.  You probably never get feedback when you play outdoors and you know how tough it is in small rehearsal rooms or clubs with 8' ceilings.  The tight space simply reflects way more sound back into your mic, which is what causes feedback in the first place.

Share this post


Link to post
Share on other sites

Thanks for the replies...

 

I've been using the Bose L1 system, so I'm very familiar with "eating" the mic, and it is when someone isn't at the mic that the feedback is occurring.  Yes, I'm going into the back panel - and the Feedback light is on green (I rarely use the side panels at the moment, which have their own Feedback light/button) - but if I recall it didn't seem to matter when I pressed to yellow and then red or even off...

 

I just remember someone talking about how easy the feedback suppression worked and how they could "...put the mic up to the speaker and let it feedback and watch/hear the unit notching it out..." (paraphrasing here)

 

I've got another show tonight and will test it out some more.  Been trying to use my L2ts more, but having the feedback issues has been keeping me with my Bose L1 Classic...

 

Thanks again for the replies!!

 

Tom

Share this post


Link to post
Share on other sites

I swear that the Feedback Suppression doesn't seem to work on either of my L2t speakers.  Doesn't matter if I select green, yellow or red.  I could not get it to stop feeding back unless I specifically went into my ParaEq and notched out the offending frequency, whether it was at 8k, 10.1k, 4k, etc (after using an RTA to find it).  I've set it up to try and "experience" the feedback suppression, but the L2t just keeps on ringing....  :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×