Jump to content
Sign in to follow this  
mganje

DT 50 Head Problem! Help please!

Recommended Posts

The fuse conected to my power connection on the back of my DT 50 Head has blown and I get no power what so ever.

 

I have replaced the fuse twice and both times it has blown right away again...........What is going on?

 

I have a gig in less than two weeks and I don't know what to do...

 

thank you

Share this post


Link to post
Share on other sites
I have replaced the fuse twice and both times it has blown right away again...........What is going on?

 

You might need to replace the tubes, but that's a big maybe. Have you tried contacting Line 6?

Share this post


Link to post
Share on other sites

There are two fuses and they are probably both bad.  Usually this indicates your power tubes need replacement.  I suggest you get your amp checked ASAP as the fuses blew for a reason.

 

Check out this thread for a bunch of good stuff for DT25, I think the fuses are the same...

 

http://line6.com/support/topic/10327-dt25-head-dead/?hl=fuse

Share this post


Link to post
Share on other sites

I have a support ticket in, waiting to hear back.

 

I put new fuses in and took the power tubes out and it still blew the fuse.......

 

think I may just have to bring it in.  

 

thanks for the responses

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×