Please ensure Javascript is enabled for purposes of website accessibility Jump to content

FBV express DEAD after connecting usb

Recommended Posts

So I have been using the FBV Express MKII with a Spider IV 30w amplifier for about 7 months without any issues

I tried to connect it with my pc (without sucess for not having the right software installed I think) and nothing went wrong.
The leds were lit when connected to the pc, but just as I tried it again on the amp nothing happened. I still get that 'click' whenever I plug it in but it seems to be dead.

I've tried to restart my pc so it could recognize the unit, but it just doesn't happen anymore

Are there any obvious solutions for this issue?

I'll be needing the pedal for the next week so please, I need to get help as soon as possible

Thank you

Link to comment
Share on other sites

When you connected it to the computer, did you use a USB cable or the CAT5 cable that connects it to the amp?


Do you have Spider Monkey installed on your computer?  That's the Line 6 software used to detect current firmware levels and to download/install updated firmware.

  • Downvote 1
Link to comment
Share on other sites

  • 1 month later...
  • 4 months later...
  • 2 weeks later...

Line 6 not interested in this issue

Clearly customer service is not a high priority, guess endorsed people get treated better, but a multi million pound company won't help you sort out a fix for your pedal that was damaged by them and their suggestion of connecting it to the servers

Link to comment
Share on other sites

  • 1 month later...
  • 10 months later...

Same thing here.  I've had my MKII connected several times to my PC and no problems.  Today, the MKII goes dead and there is no recovery.  Submitted ticket to Line 6 but do not expect a resolution.  I will be switching to another company as soon as I can sell my Line 6 amp.

Link to comment
Share on other sites

  • 2 months later...

Exactly the same here as well. Express makes a click sound when plugging in cat 5 cable but no led's light up. PC also wont recognize when connecting to USB.


Was working perfectly and then after connecting a UX1 it has stopped working....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...